这个是怎么回事?解压后安装不了

为当前最终发行版之前的所有版本提供支持
回复
afone
帖子: 22
注册时间: 2007-03-11 9:24
送出感谢: 0
接收感谢: 0

这个是怎么回事?解压后安装不了

#1

帖子 afone » 2007-03-12 9:17

想安装gsopcast-0.2.10,下载gsopcast-0.2.10.tar.bz2回来,解压,进入该文件夹,然后用这个命令安装:
./configure && make && make install
得到这样的结果:
root@ephone-desktop:/home/ephone/gsopcast-0.2.10# ./configure && make && make install
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl.exe... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking for C++ compiler default output file name... configure: error: C++ compiler cannot create executables
See `config.log' for more details.
这是怎么回事阿?没有安装c++编译器吗?
gegfried
帖子: 482
注册时间: 2006-06-29 17:30
送出感谢: 0
接收感谢: 0

#2

帖子 gegfried » 2007-03-12 9:21

看看wiki里的新手指南,没有安装基本编译环境。
头像
goldfox_79
帖子: 1937
注册时间: 2005-10-16 8:26
来自: 地球
送出感谢: 0
接收感谢: 1 次
联系:

#3

帖子 goldfox_79 » 2007-03-12 9:29

gcc什么的都没装呢,运行命令

$sudo apt-get install build-essential
afone
帖子: 22
注册时间: 2007-03-11 9:24
送出感谢: 0
接收感谢: 0

#4

帖子 afone » 2007-03-12 9:38

运行sudo apt-get install build-essential后
ephone@ephone-desktop:~$ sudo apt-get install build-essential
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.0) 但是它将不会被安装
E: 无法安装的软件包

这是怎么回事阿?
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 karron » 2007-03-12 9:40

先sudo apt-get update 一下,看看行不行.

如果不行,再看看你的源是不是你现在用的版本一致.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
afone
帖子: 22
注册时间: 2007-03-11 9:24
送出感谢: 0
接收感谢: 0

#6

帖子 afone » 2007-03-12 9:47

我用的是6.10,用的源是6.06,哪有6.10的源呢?我在教育网
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#7

帖子 xiehuoli » 2007-03-12 9:53

去论坛的WIKI去找
很多6.10的源
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 karron » 2007-03-12 14:35

ubuntu的不同版本的源仅仅是把sources.list里面的 dapper 改成 edgy 就行了,如果要用7.04的源,就改成 feity,根本不需要到处找.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
回复

回到 “老旧版本支持”