救命!用 ./configure 命令安装出现的错误。

为当前最终发行版之前的所有版本提供支持
回复
fackweb
帖子: 16
注册时间: 2007-03-12 9:31
送出感谢: 0
接收感谢: 0

救命!用 ./configure 命令安装出现的错误。

#1

帖子 fackweb » 2007-03-12 9:35

想装个 scribes 编辑器,可是在运行: ./configure 时 出现:
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.

然后在网上查找 发现了 差不多的 解答: 输入 apt-get install libc6-dev

但是又出现了新的错误:
下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.3.6-0ubuntu20.4) 但是 2.4-1ubuntu12 正要被安装
E: 无法安装的软件包

我又按照提示 输入: apt-get install libc6 可是系统提示我的Libc6 已经是最新版本了啊

真不知道该怎么办了??? ubuntu 用的还是真是麻烦啊 。。。。
ccrt
帖子: 16
注册时间: 2007-03-20 10:18
送出感谢: 0
接收感谢: 0

#2

帖子 ccrt » 2007-03-21 11:38

同命相连阿,为什么就没人理咱们呢
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2007-03-21 11:43

config.log
看了?
aptitude 安装libc6-dev的提示呢?
不进源的软件,尤其是编辑器,没必要用的。
● 鸣学
icybird_r
帖子: 20
注册时间: 2007-02-09 0:14
送出感谢: 0
接收感谢: 0

#4

帖子 icybird_r » 2007-03-27 23:47

支持.备受困扰~
romeo@romeo-laptop:~$ sudo apt-get install libc-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libc-dev is a virtual package provided by:
libc6-dev 2.3.6-0ubuntu20.4
You should explicitly select one to install.
E: Package libc-dev has no installation candidate
回复

回到 “老旧版本支持”