[问题]

为当前最终发行版之前的所有版本提供支持
回复
瓜瓜
帖子: 1
注册时间: 2007-03-13 20:08
送出感谢: 0
接收感谢: 0

[问题]

#1

帖子 瓜瓜 » 2007-03-13 20:15

出现以下问题,怎么办?求那位高人指点一下,本人菜鸟……

songyf@ubuntu:~$ sudo apt-get dist-upgrade
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
python-sip-qt3: 依赖: python2.4-sip-qt3 (>= 3.10.2-1.1ubuntu1) 但是它还没有被安装
python2.4-sip-dev: 依赖: python2.4-sip-qt3 但是它还没有被安装
E: 不能满足依赖关系。不妨试一下 -f 选项。
songyf@ubuntu:~$ su
Password:
root@ubuntu:/home/songyf# apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
python2.4-sip-qt3
下列【新】软件包将被安装:
python2.4-sip-qt3
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 3 个软件包没有被完全安装或卸载。
需要下载 0B/39.8kB 的软件包。
解压缩后会消耗掉 176kB 的额外空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 172732 个文件和目录。)
正在解压缩 python2.4-sip-qt3 (从 .../python2.4-sip-qt3_3.10.2-1.1ubuntu1_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/python2.4-sip-qt3_3.10.2-1.1ubuntu1_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/python2.4/site-packages/sipconfig.py”,它属于软件包 python2.4-sip4-qt3
dpkg-deb: 子进程 paste 被信号(Broken pipe)终止了
在处理时有错误发生:
/var/cache/apt/archives/python2.4-sip-qt3_3.10.2-1.1ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
回复

回到 “老旧版本支持”