当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Q:ubuntu server如何安装eaccelerator?
帖子发表于 : 2007-03-15 3:31 

注册: 2007-02-01 16:34
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
我急需要在ubuntu server安装eaccelerator,可是初学,看了其它资料还是装不了:如
指定php所在路径:
# export PHP_PREFIX="/data/webserver/php"
# $PHP_PREFIX/bin/phpize
执行到第二条命令时出现:bash: /usr/local/bin/phpize: No such file or directory
应该是路径不对或该文件不存在,可是我根本找不到phpize,请求高手给一份在ubuntu下安装成功的资料。


_________________
永远对新事物保持一份好奇心!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-03-23 13:08 
头像

注册: 2005-11-06 22:35
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
安装一下php5-dev包。


eAccelerator 是在 mmcache PHP 加速器/编码器的基础上更新开发的产品。它利用预先编译的缓存来提高PHP脚本的表现, 这样几乎可以完全避免超负荷编译带来的系统性能降低。 eAccelerator 的加速效果是非常明显的。昨天在一台繁忙的论坛服务器(使用vbb 2.x)测试了,速度有明显的提升,系统负荷大幅度降低。eAccelerator在Debian下安装很简单:

apt-get install gcc cpp php4-dev
wget http://ovh.dl.sourceforge.net/sourcefor ... 9.3.tar.gz
tar zxf eaccelerator-0.9.3.tar.gz
cd eaccelerator-0.9.3
export PHP_PREFIX="/usr"
$PHP_PREFIX/bin/phpize
./configure –enable-eaccelerator=shared –with-php-config=$PHP_PREFIX/bin/php-config
make
make install
mkdir /var/cache/eAcache
chmod 777 /var/cache/eAcache

然后设置 php.ini,我用的是Apache 2,php.ini是在 /etc/php4/apache2/php.ini ,在文件的最后加入如下设置:

;eAccelerator
extension="eaccelerator.so"
eaccelerator.shm_size = "1024"
eaccelerator.cache_dir = "/var/cache/eAcache"
eaccelerator.enable = "1"
eaccelerator.optimizer = "1"
eaccelerator.debug = "0"
eaccelerator.check_mtime = "1"
eaccelerator.filter = ""
eaccelerator.shm_max = "0"
eaccelerator.shm_ttl = "7200"
eaccelerator.shm_only = "1"
eaccelerator.compress = "1"
eaccelerator.compress_level = "3"
eaccelerator.keys = "shm_only"
eaccelerator.sessions = "shm_only"
eaccelerator.content = "shm_only"


页首
 用户资料  
 
3 楼 
 文章标题 : 安装cpp php5-dev出错!
帖子发表于 : 2007-04-29 18:50 

注册: 2007-02-01 16:34
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
root@wiki:~# apt-get install gcc cpp php5-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
gcc 已经是最新的版本了。
cpp 已经是最新的版本了。
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
php5-dev: 依赖: libssl-dev 但是它将不会被安装
依赖: libtool 但是它将不会被安装
E: 无法安装的软件包


_________________
永远对新事物保持一份好奇心!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译