无法安装JAVA环境

为当前最终发行版之前的所有版本提供支持
回复
storein
帖子: 163
注册时间: 2007-03-05 16:52
送出感谢: 0
接收感谢: 0

无法安装JAVA环境

#1

帖子 storein » 2007-03-16 22:02

我运行了下面的命令
sudo apt-get install sun-java6-jre

但是却提示:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
E: 无法找到软件包 sun-java6-jre


这是什么问题呢?
要如何才能安装JAVA环境呢?
谢谢!
头像
sensei
帖子: 71
注册时间: 2007-03-07 10:03
来自: 葛市柴又
送出感谢: 0
接收感谢: 0
联系:

Re: 无法安装JAVA环境

#2

帖子 sensei » 2007-03-16 22:16

storein 写了:我运行了下面的命令
sudo apt-get install sun-java6-jre

E: 无法找到软件包 sun-java6-jre
包名称错了吧?

http://wiki.ubuntu.org.cn/%E5%BF%AB%E9% ... apperDrake

sudo apt-get install sun-java5-jre
storein
帖子: 163
注册时间: 2007-03-05 16:52
送出感谢: 0
接收感谢: 0

#3

帖子 storein » 2007-03-16 22:23

我看的是现在置顶的安装指南,上面确实写的是 sun-java6-jre 的。
而且我也用的是 官方的源

deb http://archive.ubuntu.com/ubuntu/ edgy main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ edgy-security main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ edgy-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ edgy-proposed main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ edgy main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ edgy-security main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ edgy-updates main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ edgy-proposed main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu-cn/ edgy main restricted universe multiverse


不过可以试验一下安装 JAVA5.
storein
帖子: 163
注册时间: 2007-03-05 16:52
送出感谢: 0
接收感谢: 0

#4

帖子 storein » 2007-03-16 22:27

还是提示相同的错误

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
E: 无法找到软件包 sun-java5-jre
头像
sensei
帖子: 71
注册时间: 2007-03-07 10:03
来自: 葛市柴又
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 sensei » 2007-03-16 22:43

换下cn99的源看看?
头像
sensei
帖子: 71
注册时间: 2007-03-07 10:03
来自: 葛市柴又
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 sensei » 2007-03-16 22:44

换下cn99的源或者台湾大学的看看?
storein
帖子: 163
注册时间: 2007-03-05 16:52
送出感谢: 0
接收感谢: 0

#7

帖子 storein » 2007-03-16 22:51

哎呀,换成台湾的源后可以安装 java5了
可是我的是 6.10 的,不知道是否非要安装 java6哦
不过不管了,总算可以安装一个了。
先谢谢过了。
storein
帖子: 163
注册时间: 2007-03-05 16:52
送出感谢: 0
接收感谢: 0

#8

帖子 storein » 2007-03-16 22:59

看来这种急于网络的安装方法也确实还有很多问题啊,一旦有限的源有问题,就根本没有办法进行安装了。我为了安装这个JAVA环境都折腾好久了,目的就是想安装个QQ上去。实在是优点费神。
khren
帖子: 10
注册时间: 2007-03-08 11:53
送出感谢: 0
接收感谢: 0

回帖!

#9

帖子 khren » 2007-03-16 23:06

头像
sensei
帖子: 71
注册时间: 2007-03-07 10:03
来自: 葛市柴又
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 sensei » 2007-03-17 9:12

装Lumaqq呀?俺觉得gaim升级了也不错
parko
帖子: 93
注册时间: 2006-08-13 17:29
送出感谢: 0
接收感谢: 0

#11

帖子 parko » 2007-03-17 17:50

直接去java网站下载安装更好,我一次就装好了。
回复

回到 “老旧版本支持”