当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请求帮助,安装播放器时apt无法再使用,请大家帮帮忙,谢谢
帖子发表于 : 2007-03-17 21:03 
头像

注册: 2007-01-26 22:06
帖子: 236
地址: 南宁 杭州
送出感谢: 0 次
接收感谢: 0 次
hongmy525@ubuntu525:~$ sudo apt-get install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
totem: 依赖: totem-gstreamer (>= 2.16.2-0ubuntu2) 但是它还没有被安装 或
totem-xine (>= 2.16.2-0ubuntu2) 但是它还没有被安装
totem-mozilla: 依赖: totem-xine (>= 2.16.2-0ubuntu2) 但是它还没有被安装 或
totem-gstreamer (>= 2.16.2-0ubuntu2) 但是它还没有被安装
E: 不能满足依赖关系。不妨试一下 -f 选项。



hongmy525@ubuntu525:~$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
totem-gstreamer
建议安装的软件包:
gstreamer0.10-plugins-ugly gstreamer0.10-ffmpeg
下列【新】软件包将被安装:
totem-gstreamer
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 76 个软件未被升级。
需要下载 0B/1133kB 的软件包。
解压缩后会消耗掉 6136kB 的额外空间。
您希望继续执行吗?[Y/n]y
【警告】:下列的软件包不能通过验证!
totem-gstreamer
不经验证就安装这些软件包么?[y/N] y
dpkg: 解析错误,在“/var/lib/dpkg/status”文件的第“11616”行附近 软件包“dictionaries-common”:
“Conflicts”字段,无效的软件包名“german”:必须以字母开头
E: Sub-process /usr/bin/dpkg returned an error code (2)


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-03-17 22:35 
头像

注册: 2007-01-26 22:06
帖子: 236
地址: 南宁 杭州
送出感谢: 0 次
接收感谢: 0 次
我在网上找了好久都没有找到解决的方案,不想轻易重装系统,感觉也不是什么大问题,只是刚开始不熟悉,请大家帮帮忙,谢谢了


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-03-18 0:03 
头像

注册: 2007-03-01 20:46
帖子: 2393
地址: 湖南长沙
送出感谢: 0 次
接收感谢: 0 次
我似乎遇到过类似的

首先,检查你的/etc/apt/sources.list文件里的源,看看那些源的版本和你Ubuntu的版本是否一样~~
例如你的Ubuntu版本是Edgy,那么源应该是:

deb <web_url> edgy main restricted universe multiverse
......

注意那个edgy,如果你的Ubuntu是Dapper, 那么就改成dapper,以此类推。<web_url>部分是你的源URL

如果这些都对的话,用新立得把totem这个软件包重装一次(会自动带上依赖的)

引用:
hongmy525@ubuntu525:~$ sudo apt-get install


你这里怎么没有带上任何软件包的名字?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-03-18 9:10 
头像

注册: 2007-01-26 22:06
帖子: 236
地址: 南宁 杭州
送出感谢: 0 次
接收感谢: 0 次
hongmy525@ubuntu525:~$ sudo apt-get install

这个部分我只是想回复问题的现场来发帖,我检查了我的源没有什么问题,我现在不知道怎么安装totem-gstreamer ,已经下载下来了,但是老实装不上,用apt-get其他的也弄不上,帮说详细点点:)


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-03-18 9:15 
头像

注册: 2007-01-26 22:06
帖子: 236
地址: 南宁 杭州
送出感谢: 0 次
接收感谢: 0 次
我想换一个源的时候出现了这样的一个问题

hongmy525@ubuntu525:~$ sudo apt-get dist-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
totem: 依赖: totem-gstreamer (>= 2.16.2-0ubuntu2) 但是它还没有被安装 或
totem-xine (>= 2.16.2-0ubuntu2) 但是它还没有被安装
totem-mozilla: 依赖: totem-xine (>= 2.16.2-0ubuntu2) 但是它还没有被安装 或
totem-gstreamer (>= 2.16.2-0ubuntu2) 但是它还没有被安装
E: 不能满足依赖关系。不妨试一下 -f 选项。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-03-18 10:28 
头像

注册: 2007-01-26 22:06
帖子: 236
地址: 南宁 杭州
送出感谢: 0 次
接收感谢: 0 次
现在新立得只要想用他安装什么软件,都会有类似下面的字出来

hongmy525@ubuntu525:~$ sudo apt-get install rar unrar
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
totem: 依赖: totem-gstreamer (>= 2.16.2-0ubuntu2) 但是它将不会被安装 或
totem-xine (>= 2.16.2-0ubuntu2) 但是它将不会被安装
totem-mozilla: 依赖: totem-xine (>= 2.16.2-0ubuntu2) 但是它将不会被安装 或
totem-gstreamer (>= 2.16.2-0ubuntu2) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-03-18 10:53 
头像

注册: 2007-03-01 20:46
帖子: 2393
地址: 湖南长沙
送出感谢: 0 次
接收感谢: 0 次
那你去“新立得”里边看看是否有totem-xine这个软件包,有可能你的源里边没有这个才会这样,而且看看你的源是否开通了multiverse, universe和restricted模块~~

给你看看我的源列表(我的是Feisty的哦,别弄错了):

代码:
## Main Packages
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ feisty main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ feisty main restricted universe multiverse

## Main Updates
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ feisty-updates main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ feisty-updates main restricted universe multiverse

## Backports
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ feisty-backports main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ feisty-backports main restricted universe multiverse

#Security Updates
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ feisty-security main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ feisty-security main restricted universe multiverse

deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ feisty-proposed main restricted universe multiverse

## Sevea’s Repository (Multimedia Packages)
deb http://seveas.imbrandon.com/ edgy-seveas extras seveas-meta custom
deb-src http://seveas.imbrandon.com/ edgy-seveas extras seveas-meta custom

## Samba
deb http://www.linux2go.dk/ubuntu feisty main
deb-src http://www.linux2go.dk/ubuntu feisty main

## Cafuego’s Edgy Stuff: Broadcom kernel firmwares, google-earth, beagle
deb http://au.ubuntu.cafuego.net feisty-cafuego all
deb-src http://au.ubuntu.cafuego.net feisty-cafuego all

## Audacious
deb http://static.audacious-media-player.org/ubuntu edgy main
deb-src http://static.audacious-media-player.org/ubuntu edgy main

#deb http://ubuntu.cn99.com/ubuntu/ feisty main restricted universe multiverse
#deb http://ubuntu.cn99.com/ubuntu/ feisty-updates main restricted universe multiverse
#deb http://ubuntu.cn99.com/ubuntu/ feisty-security main restricted universe multiverse
#deb http://ubuntu.cn99.com/ubuntu/ feisty-backports main restricted universe multiverse

deb http://us.archive.ubuntu.com/ubuntu feisty main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu feisty-security main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu feisty-updates main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu feisty-backports main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu feisty-proposed main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu feisty main restricted universe
deb-src http://us.archive.ubuntu.com/ubuntu feisty-security main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu feisty-updates main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu feisty-backports main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu feisty-proposed main restricted universe multiverse


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-03-18 11:04 
头像

注册: 2007-01-26 22:06
帖子: 236
地址: 南宁 杭州
送出感谢: 0 次
接收感谢: 0 次
我刚刚开始用ubuntu,看不懂你的源,我的源用的是快速指南里面的台湾的那个源

请教一下该如何修复损坏的依赖关系?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-03-18 11:21 
头像

注册: 2007-03-01 20:46
帖子: 2393
地址: 湖南长沙
送出感谢: 0 次
接收感谢: 0 次
引用:
请教一下该如何修复损坏的依赖关系?


sudo apt-get install -f


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-03-18 11:31 
头像

注册: 2007-01-26 22:06
帖子: 236
地址: 南宁 杭州
送出感谢: 0 次
接收感谢: 0 次
这个命令好像不行阿,你现在是在windows下面马?


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-03-18 11:57 
头像

注册: 2007-01-26 22:06
帖子: 236
地址: 南宁 杭州
送出感谢: 0 次
接收感谢: 0 次
算了,我重新安装~!

刚才我把/var/cache/apt/下的东西给删除了,这个好像很不好修复,我以为只是小问题,今天学校网速太慢,这样效率不够了,谢谢


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译