[问题]依赖关系损坏怎么解决?

为当前最终发行版之前的所有版本提供支持
回复
llluyan
帖子: 42
注册时间: 2007-03-10 7:55
送出感谢: 0
接收感谢: 0

[问题]依赖关系损坏怎么解决?

#1

帖子 llluyan » 2007-03-18 20:47

openoffice.org: 依赖: openoffice.org-core (> 2.0.2) 但是它将不会被安装
openoffice.org-base: 依赖: openoffice.org-core (> 2.0.3) 但是它将不会被安装
openoffice.org-calc: 依赖: openoffice.org-core (> 2.0.3) 但是它将不会被安装
openoffice.org-common: 依赖: openoffice.org-core (> 2.0.2) 但是它将不会被安装 或
openoffice.org-core-experimental (> 2.0.2) 但却无法安装它
openoffice.org-draw: 依赖: openoffice.org-core (> 2.0.3) 但是它将不会被安装
openoffice.org-gtk: 依赖: openoffice.org-core (> 2.0.3) 但是它将不会被安装
openoffice.org-help-zh-cn: 依赖: openoffice.org-core (>= 2.0.3) 但是它将不会被安装 或
language-support-zh 但是它将不会被安装
openoffice.org-impress: 依赖: openoffice.org-core (> 2.0.2) 但是它将不会被安装 openoffice.org-java-common: 依赖: openoffice.org-common (> 2.0.3) 但是 2.0.2-2ubuntu12.1 正要被安装
openoffice.org-l10n-zh-cn: 依赖: openoffice.org-common (>= 2.0.3) 但是 2.0.2-2ubuntu12.1 正要被安装 或
language-support-zh 但是它将不会被安装
openoffice.org-l10n-zh-tw: 依赖: openoffice.org-common (>= 2.0.3) 但是 2.0.2-2ubuntu12.1 正要被安装 或
language-support-zh 但是它将不会被安装
openoffice.org-math: 依赖: openoffice.org-core (> 2.0.3) 但是它将不会被安装
openoffice.org-writer: 依赖: openoffice.org-core (> 2.0.3) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
我想在添加删除程序里卸载open office 提示说“一个或多个程序依赖openoffice”,我怎么办阿(我用的中科大源6.06)
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

Re: [问题]依赖关系损坏怎么解决?

#2

帖子 dbzhang800 » 2007-03-18 20:51

llluyan 写了:openoffice.org: 依赖: openoffice.org-core (> 2.0.2) 但是它将不会被安装
openoffice.org-base: 依赖: openoffice.org-core (> 2.0.3) 但是它将不会被安装
openoffice.org-calc: 依赖: openoffice.org-core (> 2.0.3) 但是它将不会被安装
openoffice.org-common: 依赖: openoffice.org-core (> 2.0.2) 但是它将不会被安装 或
openoffice.org-core-experimental (> 2.0.2) 但却无法安装它
openoffice.org-draw: 依赖: openoffice.org-core (> 2.0.3) 但是它将不会被安装
openoffice.org-gtk: 依赖: openoffice.org-core (> 2.0.3) 但是它将不会被安装
openoffice.org-help-zh-cn: 依赖: openoffice.org-core (>= 2.0.3) 但是它将不会被安装 或
language-support-zh 但是它将不会被安装
openoffice.org-impress: 依赖: openoffice.org-core (> 2.0.2) 但是它将不会被安装 openoffice.org-java-common: 依赖: openoffice.org-common (> 2.0.3) 但是 2.0.2-2ubuntu12.1 正要被安装
openoffice.org-l10n-zh-cn: 依赖: openoffice.org-common (>= 2.0.3) 但是 2.0.2-2ubuntu12.1 正要被安装 或
language-support-zh 但是它将不会被安装
openoffice.org-l10n-zh-tw: 依赖: openoffice.org-common (>= 2.0.3) 但是 2.0.2-2ubuntu12.1 正要被安装 或
language-support-zh 但是它将不会被安装
openoffice.org-math: 依赖: openoffice.org-core (> 2.0.3) 但是它将不会被安装
openoffice.org-writer: 依赖: openoffice.org-core (> 2.0.3) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
我想在添加删除程序里卸载open office 提示说“一个或多个程序依赖openoffice”,我怎么办阿(我用的中科大源6.06)
llluyan
帖子: 42
注册时间: 2007-03-10 7:55
送出感谢: 0
接收感谢: 0

#3

帖子 llluyan » 2007-03-18 20:58

感谢你的回答 我试了一下 结果是:
ly@ly-desktop:~$ sudo apt-get -f install
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
openoffice.org-common openoffice.org-core openoffice.org-impress
下列【新】软件包将被安装:
openoffice.org-core
下列的软件包将被升级:
openoffice.org-common openoffice.org-impress
共升级了 2 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 14 个软件未被升 级。
有 8 个软件包没有被完全安装或卸载。
需要下载 0B/55.7MB 的软件包。
解压缩后会消耗掉 81.1MB 的额外空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 76895 个文件和目录。)
正预备替换 openoffice.org-impress 2.0.2-2ubuntu12.1-1 (使用 .../openoffice.org-impress_2.0.3-6dapper1-1_amd64.deb) ...
正在解压缩将用于更替的包文件 openoffice.org-impress ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-impress_2.0.3-6dapper1-1_amd64.deb (--unpack)时出错:
正试图覆盖“/usr/lib/openoffice/share/registry/modules/org/openoffice/TypeDetection/Filter/fcfg_impressgraphics_filters.xcu”,它属于软件包 openoffice.org-common
dpkg:关于含有 openoffice.org-common 的 .../openoffice.org-common_2.0.3-6dapper3_all.deb:
openoffice.org-common 冲突于 openoffice.org-impress (<< 2.0.3)
openoffice.org-impress (版本为 2.0.2-2ubuntu12.1-1)现在 已安装完毕。
dpkg:处理 /var/cache/apt/archives/openoffice.org-common_2.0.3-6dapper3_all.deb (--unpack)时出错:
软件包相互冲突 - 将不安装 openoffice.org-common
dpkg:关于含有 openoffice.org-core 的 .../openoffice.org-core_2.0.3-6dapper1-1_amd64.deb:
openoffice.org-core 冲突于 openoffice.org-impress (<< 2.0.3)
openoffice.org-impress (版本为 2.0.2-2ubuntu12.1-1)现在 已安装完毕。
dpkg:处理 /var/cache/apt/archives/openoffice.org-core_2.0.3-6dapper1-1_amd64.deb (--unpack)时出错:
软件包相互冲突 - 将不安装 openoffice.org-core
在处理时有错误发生:
/var/cache/apt/archives/openoffice.org-impress_2.0.3-6dapper1-1_amd64.deb
/var/cache/apt/archives/openoffice.org-common_2.0.3-6dapper3_all.deb
/var/cache/apt/archives/openoffice.org-core_2.0.3-6dapper1-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
头像
avauntage
帖子: 570
注册时间: 2005-09-22 10:15
来自: 北京
送出感谢: 0
接收感谢: 0

#4

帖子 avauntage » 2007-03-19 9:34

试试以下的命令:
$ sudo apt-get update
$ sudo dselect update
$ sudo dpkg --configure --pending
$ sudo apt-get --purge remove openoffice.org
祝你好运!
空手把锄头,步行骑水牛;人在桥上过,人流水不流。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#5

帖子 eexpress » 2007-03-19 9:38

avauntage 写了:试试以下的命令:
$ sudo apt-get update
$ sudo dselect update
$ sudo dpkg --configure --pending
$ sudo apt-get --purge remove openoffice.org
祝你好运!
dselect都出来了。nnd。不知道推荐aptitude啊。这么好的东西。比apt-get强哦。命令完全兼容。
● 鸣学
头像
avauntage
帖子: 570
注册时间: 2005-09-22 10:15
来自: 北京
送出感谢: 0
接收感谢: 0

#6

帖子 avauntage » 2007-03-19 14:57

nnd。偶没用过aptitude啊,你倒是教教大家!
空手把锄头,步行骑水牛;人在桥上过,人流水不流。
回复

回到 “老旧版本支持”