当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 无法进入X 的困扰,请帮助
帖子发表于 : 2005-10-20 0:14 

注册: 2005-10-20 0:10
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
Ubuntu 5.10 i386.iso光盘安装,第一阶段正常,然后取出光盘,重启。进入系统后是package的配置,其间由于字符显示的问题,有两个对话框有很多实心的正方形字符块,代表字符(估计是汉字,我也不知道Ubuntu为什么这样),所幸一路OK。顺利进入gnome图形界面,一般使用上网、声音都正常。我看了一下 /etc/X11/xorg.conf
Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

/dev/目录下有input/mice

好了,问题来了(我安装几次都是这个问题),没有做任何改动,重启系统,这次在Ubuntu登陆画面中失败,无法进入图形界面,只得进入文本登陆。startx失败。下面是Xorg.0.log失败内容:
(**) Option "Protocol" "ImPS/2"
(**) Configured Mouse: Device: "/dev/input/mice"
(**) Configured Mouse: Protocol: "ImPS/2"
(**) Option "CorePointer"
(**) Configured Mouse: Core Pointer
(**) Option "Device" "/dev/input/mice"
(EE) xf86OpenSerial: Cannot open device /dev/input/mice
No such file or directory.
(EE) Configured Mouse: cannot open input device
(EE) PreInit failed for input device "Configured Mouse"
(II) UnloadModule: "mouse"
(WW) No core pointer registered
(II) XINPUT: Adding extended input device "Generic Keyboard" (type: KEYBOARD)
No core pointer

Fatal server error:
failed to initialize core devices

Please consult the The X.Org Foundation support
at http://wiki.X.Org

我看了一下/dev,没有input/mice,当然进入不了。我纳闷系统为什么要删除/dev/input/mice?我安装了3次,每次都是这个问题,第一次进入了,重启就失败。真是郁闷。请各位高手指点一下,Linux我用了两三年了,遇到这样的事情实在头大,估计对Ubuntu比较陌生。

之后有时又能进入图形界面,但大部分时候是失败。可以确定的是鼠标和硬件良好,因为在MS Windows,和其他Linux下都完好无损。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-10-20 0:18 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
那你可以安装了,就把mice目录复制出来,没有了,字符界面下登录复制回去。
这里的信息只能看到是鼠标没有加载,并不是鼠标本身问题。


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-10-20 0:23 

注册: 2005-10-20 0:10
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
谢谢回复,我这样复制过,复制是成功的,但是启动仍然失败,说是打不开这个设备文件。我google了一下,对于 /dev/input/mice ,说是驱上 mousedev 和psmouse 就好了,但是我用 modprobe,说是找不到这两个模块。
FATAL: Module psmouse not found.

FATAL: Module mousedev not found.

我刚刚换了鼠标,还是老问题。


最后由 viskanta 编辑于 2005-10-20 0:42,总共编辑了 1 次

页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-10-20 0:29 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
我的是这2个。modprobe试试。
$ lsmod|grep mouse
psmouse 21320 0
mousedev 11288 1


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-10-20 0:32 

注册: 2005-10-20 0:10
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
谢谢eexpress,应该就是mousedev 和psmouse,但是怎么加载啊?我用modprobe psmouse,
modprobe moudedev
不成功啊


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-10-20 1:12 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
加载就是modprobe。开始说了。应该看一下dmesg,系统启动的过程。$ less /var/log/syslog.0这样的信息。


_________________
● 鸣学


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-10-20 1:30 

注册: 2005-10-20 0:10
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
为什么Ubuntu 5.10 i386.iso光盘安装中没有这两个模块呢?我在/lib/modules里面看到 mousedev.ko, 是这个吗?但是无法 modprobe啊。

再说用官方的安装光盘安装不会出这么样的错误的,我想还是我哪里错了,但是我似乎没有动什么设置,安装也很顺利啊。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-10-20 9:24 
头像

注册: 2005-10-20 8:43
帖子: 11
地址: China
送出感谢: 0 次
接收感谢: 0 次
I had the same problem!
But when I choose English as my default language when the Installition start,the problem disappeared!I suggest you trying so..
I am now working in a English evoriment,downloading Zh-cn UTF8 local files and Chinese input method via internet,haha :) GL~


_________________
Under the moonlight.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译