问一个关于beryl的很弱的问题

为当前最终发行版之前的所有版本提供支持
回复
kernelforce
帖子: 57
注册时间: 2007-03-18 17:05
送出感谢: 0
接收感谢: 0

问一个关于beryl的很弱的问题

#1

帖子 kernelforce » 2007-03-19 12:54

今天上午刚装的xgl和beryl,是ati x1400的显卡。
用 beryl-manager启动,也看到红宝石图标了
然后在终端里看到
XGL Absent, checking for NVIDIA
Nvidia Absent, checking for texture_from_pixmap
texture_from_pixmap Present
beryl: No composite extension

不知道这算启动beryl了没?怎么看3d效果呢?按Ctrl+Alt+PageDown(Next)没反应!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-03-19 12:57

没安装nvidia-glx驱动
● 鸣学
kernelforce
帖子: 57
注册时间: 2007-03-18 17:05
送出感谢: 0
接收感谢: 0

#3

帖子 kernelforce » 2007-03-19 13:04

我是ati的显卡诶...
是按照这个http://forum.ubuntu.org.cn/viewtopic.php?t=35403做的
也没说要装跟Nvida有关的东西嘛
问题出在哪里?
头像
Amankwah
帖子: 624
注册时间: 2006-10-16 7:24
来自: 安康/西安/广州
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 Amankwah » 2007-03-19 13:04

ATI的显卡装Nv-glx干什么?
应该是用xgl应该用的就是fglrx的驱动,所以是/etc/X11/xorg.conf后面少了
·

代码: 全选

Section "Extensions"
        Option  "Composite" "Disable"
EndSection

Section "ServerFlags"
        Option  "AIGLX" "off"
EndSection

加入你的xorg.conf中应该就可以了
读书取正,读易取变,读骚取幽,读庄取达,读汉文取坚,最有味卷中岁月。
与菊同野,与梅同疏,与莲同洁,与兰同芳,与海棠同韵,定自称花里神仙。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#5

帖子 eexpress » 2007-03-19 13:16

真是。提示这个作什么
● 鸣学
kernelforce
帖子: 57
注册时间: 2007-03-18 17:05
送出感谢: 0
接收感谢: 0

#6

帖子 kernelforce » 2007-03-19 13:23

Amankwah 写了:ATI的显卡装Nv-glx干什么?
应该是用xgl应该用的就是fglrx的驱动,所以是/etc/X11/xorg.conf后面少了
·

代码: 全选

Section "Extensions"
        Option  "Composite" "Disable"
EndSection

Section "ServerFlags"
        Option  "AIGLX" "off"
EndSection

加入你的xorg.conf中应该就可以了


照做了,还是没反应,不知道怎么办
头像
Amankwah
帖子: 624
注册时间: 2006-10-16 7:24
来自: 安康/西安/广州
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 Amankwah » 2007-03-19 13:24

那个提示信息的意思就是,XGl没有正确运行,aiglx也没有,所以beryl就没有。
看看,xgl的设置和显卡驱动吧
读书取正,读易取变,读骚取幽,读庄取达,读汉文取坚,最有味卷中岁月。
与菊同野,与梅同疏,与莲同洁,与兰同芳,与海棠同韵,定自称花里神仙。
kernelforce
帖子: 57
注册时间: 2007-03-18 17:05
送出感谢: 0
接收感谢: 0

#8

帖子 kernelforce » 2007-03-19 13:39

显卡是根据http://forum.ubuntu.org.cn/viewtopic.php?t=26188里面说的做的
xgl的安装
sudo apt-get install xserver-xgl
xgl的设置
sudo gedit /usr/local/bin/startxgl.sh
内容如下:
#!/bin/sh
Xgl -fullscreen :1 -ac -br -accel glx:pbuffer -accel xv:pbuffer &
sleep 4
export DISPLAY=:1
exec gnome-session
如果出现问题的话,尝试
#!/bin/sh
Xgl :1 -fullscreen -ac -br -accel glx:pbuffer -accel xv:pbuffer &
sleep 4
export DISPLAY=:1
exec gnome-session
然后 sudo chmod a+x /usr/local/bin/startxgl.sh
注:如果使用以上脚本导致你的字体或鼠标配置不能正常载入,那么用"exec
/etc/X11/Xsession"代替上面的“exec gnome-session”
sudo gedit /usr/share/xsessions/xgl.desktop
内容:
[Desktop Entry]
Encoding=UTF-8
Name=Xgl
Exec=/usr/local/bin/startxgl.sh
Icon=
Type=Application


在xorg.conf中加入了

代码: 全选

Section "Extensions"
        Option  "Composite" "Disable"
EndSection

Section "ServerFlags"
        Option  "AIGLX" "off"
EndSection

在终端中启动beryl依然出现

代码: 全选

XGL Absent, checking for NVIDIA
Nvidia Absent, checking for texture_from_pixmap
texture_from_pixmap Present
beryl: No composite extension

茫然ing...
kernelforce
帖子: 57
注册时间: 2007-03-18 17:05
送出感谢: 0
接收感谢: 0

#9

帖子 kernelforce » 2007-03-19 18:19

问题解决,原来要在系统->首选项->会话 中手动添加Xgl会话选项...
太弱了...
drongh
帖子: 1038
注册时间: 2007-01-10 9:32
送出感谢: 4 次
接收感谢: 5 次

#10

帖子 drongh » 2007-03-19 18:37

怎么添加,写详细点,我也是这个没成功,不过我安装的是ati的开源驱动!!!
头像
Amankwah
帖子: 624
注册时间: 2006-10-16 7:24
来自: 安康/西安/广州
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 Amankwah » 2007-03-20 8:31

如果你是6.10以后的版本。开源驱动不用其他的设置,也不用XGL,直接运行就可以了用的aiglx,特效少点吧,但直接就能用
读书取正,读易取变,读骚取幽,读庄取达,读汉文取坚,最有味卷中岁月。
与菊同野,与梅同疏,与莲同洁,与兰同芳,与海棠同韵,定自称花里神仙。
kernelforce
帖子: 57
注册时间: 2007-03-18 17:05
送出感谢: 0
接收感谢: 0

#12

帖子 kernelforce » 2007-03-21 0:35

就是在会话里面点添加..,然后就输入Xgl即可,记得在登录的时候点左下方的“选项->会话”,再选择Xgl。
问题在于,现在启动了Xgl、beryl之后,无法调用scim输入法,不知道为什么?在gnome下可以调出的....再次茫然ing...
回复

回到 “老旧版本支持”