[求助]无法安装emacs

为当前最终发行版之前的所有版本提供支持
回复
moxosyuri
帖子: 3
注册时间: 2007-03-20 10:33
送出感谢: 0
接收感谢: 0

[求助]无法安装emacs

#1

帖子 moxosyuri » 2007-03-20 10:52

我刚刚安装了ubuntu,想装emacs,结果总是不行望各位指点,情况如下:

首先用 应用程序->添加/删除 找到里面的 Emacs 21 (X11),提示的信息如下:

Emacs 21 (X11)
Emacs 21 (X11)无法安装于您的计算机类型(i386)。应用程序需要特殊的硬件或者提供者不再支持您的计算机类

另外,我试了试其他的软件,大部分都是同样的提示信息,我用的是windows xp下的VMware,不知有没有关系。

然后在终端中操做,结果如下:

yuri@yuri-desktop:~$ sudo apt-get install emacs
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
现在没有可用的软件包 emacs,但是它被其它的软件包引用了。
这可能意味着这个缺失的软件包可能已被废弃,
或者只能在其他发布源中找到
E: 软件包 emacs 还没有可供安装的候选者
yuri@yuri-desktop:~$

不知道是怎么回事啊,望各位高手指点!!
moxosyuri
帖子: 3
注册时间: 2007-03-20 10:33
送出感谢: 0
接收感谢: 0

晕,还是不行

#2

帖子 moxosyuri » 2007-03-20 11:03

我去下了个 emacs-21.3.tar.gz, 解压后操作:

yuri@yuri-desktop:~/emacs-21.3$ ./configure
loading cache ./config.cache
checking host system type... i686-pc-linux-gnulibc1
checking for gcc... gcc
checking whether the C compiler (gcc ) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.
yuri@yuri-desktop:~/emacs-21.3$ make
make: *** 没有指明目标并且找不到 makefile。 停止。
yuri@yuri-desktop:~/emacs-21.3$ sudo make install
make: *** 没有规则可以创建目标“install”。 停止。

然而gcc是安装了的(从系统软件包中看,还有gcc命令和 man gcc都可以用),我现在是彻底晕了,大家帮着看看啊。
蛋壳羊
帖子: 113
注册时间: 2006-11-04 19:56
送出感谢: 0
接收感谢: 0

#3

帖子 蛋壳羊 » 2007-04-16 18:32

我今天也出现了类似的问题
用sudo apt-get update
更新一下软件列表就可以了
回复

回到 “老旧版本支持”