新手急求帮助!!请各位高手帮帮忙阿

为当前最终发行版之前的所有版本提供支持
回复
bellyxiaoxiao
帖子: 7
注册时间: 2007-01-25 19:25
送出感谢: 0
接收感谢: 0
联系:

新手急求帮助!!请各位高手帮帮忙阿

#1

帖子 bellyxiaoxiao » 2007-03-20 13:02

:? 前几天刚买的笔记本,昨天开始在UBUNTU下进行设置,先都还没什么问题,后来再安装软件包的时候出现了我实在解决不了的问题,在BASH下用apt-get和在打开新立德的时候都会出现以下的报错信息:

E: Dynamic MMap ran out of room
E: Dynamic MMap ran out of room
E: Dynamic MMap ran out of room
E: 处理 language-pack-kde-bn (NewVersion1)时出错
E: Problem with MergeList /var/lib/apt/lists/mirror9.net9.org_ubuntu_dists_dapper-proposed_main_binary-i386_Packages
E: 无法解析或打开软件包列表或状态文件。

之前就修改过更新源 /etc/apt/sources.list和/etc/X11/xorg.conf这两个文件,请高手帮帮忙,现在什么都装 不了阿
我装的UBUNTU是这里BT下的Ubuntu中文社区发行版
头像
sense
帖子: 308
注册时间: 2007-02-14 13:54
送出感谢: 0
接收感谢: 0

#2

帖子 sense » 2007-03-20 15:22

你把 sources.list 恢复一下试一试
头像
5luoya
帖子: 146
注册时间: 2006-10-31 14:41
送出感谢: 0
接收感谢: 0

#3

帖子 5luoya » 2007-03-20 15:32

软件包过大,可能需要适当增加 apt 的缓存上限。
bellyxiaoxiao
帖子: 7
注册时间: 2007-01-25 19:25
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 bellyxiaoxiao » 2007-03-21 15:37

请问该怎么做啊?增大APT缓冲上限
头像
5luoya
帖子: 146
注册时间: 2006-10-31 14:41
送出感谢: 0
接收感谢: 0

#5

帖子 5luoya » 2007-03-21 19:04

在 /etc/apt/apt.conf (如没有则新建)中加入:

APT::Cache-Limit 12582912;

先 man apt.conf 一下了解更加详细的参数说明。
bellyxiaoxiao
帖子: 7
注册时间: 2007-01-25 19:25
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 bellyxiaoxiao » 2007-03-21 22:40

呵呵,谢谢了哈,但是还是不行阿,干脆我 明天重装算了。。
头像
5luoya
帖子: 146
注册时间: 2006-10-31 14:41
送出感谢: 0
接收感谢: 0

#7

帖子 5luoya » 2007-03-22 11:56

试试把它加入 /etc/apt/ap.conf.d/70debconf 而不是 apt.conf。
另外大小可以按需调节,12582912(Byte)=12(M)*1024*1024
bellyxiaoxiao
帖子: 7
注册时间: 2007-01-25 19:25
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 bellyxiaoxiao » 2007-03-22 13:11

昨天我看了下APT-GET的帮助文档,用apt-cache search forcs这个命令将apt的缓存清理了一下,结果就可以了,呵呵
(不知道为什么,按道理说应该不会阿。。我分盘的时候直接给/分的34G,看来下次要详细点分了)
但当时已经快没时间了,所以我就把正在下载的进程关了,谁知道今天又出现新的问题。。。

【警告】:下列的软件包不能通过验证!
libartsc0 libdvdread3 libmp4v2-0 libfaac0 libgii1-target-x libgii1 libggi2 liblame0 libmpcdec3
libpostproc0 libungif4g libxvidcore4 libxvmc1 mplayer-skins mplayer mozilla-mplayer
mplayer-fonts mencoder
E: 碰到了一些问题,您使用了 -y 选项,但是没有用 --force-yes

用apt-get clean 也没用。。。说是被锁住了
哎,看来我的UBUNTU之路还很长阿。。
头像
5luoya
帖子: 146
注册时间: 2006-10-31 14:41
送出感谢: 0
接收感谢: 0

#9

帖子 5luoya » 2007-03-22 15:01

apt默认指定 cache 的大小,跟分区的详细与否应该没什么直接的干系。

如果在安装过程中出现中断,然后发现该软件包既不能重装又不能删除,可以加个 -f 试试:

代码: 全选

# sudo apt-get -f install <package>
E: 碰到了一些问题,您使用了 -y 选项,但是没有用 --force-yes
在出现问题时注意一下“提示”还是比较重要的。
bellyxiaoxiao
帖子: 7
注册时间: 2007-01-25 19:25
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 bellyxiaoxiao » 2007-03-22 19:57

恩,谢谢这位大哥了,一直是用新立德和AUTOMATIX装的东西,现在知道他们的功能全是apt的,看来还是命令好用阿,呵呵
回复

回到 “老旧版本支持”