ubuntu 不允许用root登录啊?!

为当前最终发行版之前的所有版本提供支持
回复
conanca
帖子: 7
注册时间: 2007-03-21 19:03
送出感谢: 0
接收感谢: 0

ubuntu 不允许用root登录啊?!

#1

帖子 conanca » 2007-03-21 19:16

郁闷~~
上次由 conanca 在 2007-05-05 20:04,总共编辑 1 次。
头像
fallleaf
帖子: 694
注册时间: 2006-12-29 20:13
送出感谢: 0
接收感谢: 0

Re: [求助]第一次使用ubuntu....遇上好多问题

#2

帖子 fallleaf » 2007-03-21 19:24

conanca 写了:我刚刚Linux,以前玩过一小段时间SUSE,昨天刚装上ubuntu,遇上诸多问题,我都快崩溃了。。。


首先就是装各种软件,我下的那些未编译的,一个都没装上,只好装编译好的。 原因就是配置源代码树时,总是出现“ C compiler cannot create executables”

去网上搜了半天,说要配置什么gcc,我又运行“apt-get install gcc libc6-dev”,结果当前用户又没权限。

于是用ROOT用户进,又说找不到apt命令。

哪位大侠指点我一下阿!!!
建议先到wiki看一下ubuntu的基本知识。这些问题都是很基本的东西
bocar
帖子: 3
注册时间: 2006-09-13 10:03
送出感谢: 0
接收感谢: 0

#3

帖子 bocar » 2007-03-22 14:40

装gcc应该用下面的命令:

代码: 全选

sudo apt-get install build-essential
头像
fallleaf
帖子: 694
注册时间: 2006-12-29 20:13
送出感谢: 0
接收感谢: 0

Re: [求助]第一次使用ubuntu....遇上好多问题

#4

帖子 fallleaf » 2007-03-22 19:33

conanca 写了:
E: 无法打开锁文件 /var/lib/dpkg/lock - open (13 Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
这大概是因为你同时开着新立得或者是“安装-删除程序”,因为不能用时开两个软件安装管理器。
storein
帖子: 163
注册时间: 2007-03-05 16:52
送出感谢: 0
接收感谢: 0

#5

帖子 storein » 2007-03-22 22:25

慢慢来,不要慌,每件事情都有他的解决方法的。

1. 第一个问题,你需要安装一个下面这个东西,我不知道干什么用处的,但是安装后就没有你那个问题了。
apt-get install libc6-dev

2. 第二个问题是你在多处想运行 apt-get 来进行软件升级,比如你在两个终端窗口中运行了 apt-get
比如你在开启 新的力的同时运行 apt-get ,只要你关闭一个,重新再来一次,就没有问题了。
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#6

帖子 zhuqin_83 » 2007-03-23 2:45

点我签名档 :D
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
yjwork
帖子: 422
注册时间: 2006-10-24 11:46
系统: debian
送出感谢: 0
接收感谢: 2 次

#7

帖子 yjwork » 2007-03-23 15:07

ROOT?
root!
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 SuperWar3Fan » 2007-03-23 15:14

重新启动电脑!
进入终端
sudo apt-get install build-essential
有空的话,请访问我的BlogUbuntu高地
作人要厚道
帖子: 81
注册时间: 2007-02-23 8:59
送出感谢: 0
接收感谢: 0

#9

帖子 作人要厚道 » 2007-03-25 23:39

慢慢来,多搞几次就好了。
呵呵
believer82
帖子: 59
注册时间: 2006-09-14 23:56
送出感谢: 0
接收感谢: 0

#10

帖子 believer82 » 2007-03-26 15:09

加sudo 就ok了
回复

回到 “老旧版本支持”