[问题]安装ubuntu后我的XP就无法启动了?!求助,急!

为当前最终发行版之前的所有版本提供支持
回复
bonjourworld
帖子: 29
注册时间: 2007-03-21 17:31
送出感谢: 0
接收感谢: 0

[问题]安装ubuntu后我的XP就无法启动了?!求助,急!

#1

帖子 bonjourworld » 2007-03-21 22:36

安装了ubuntu后我的XP一启动就蓝屏!!
害的我格了整个硬盘! 可重装了XP再装U,XP还是蓝屏,而且原来的分区都没了,变成一个C盘了都,格式还是未知!

谁知道怎么回事阿?!!!
bonjourworld
帖子: 29
注册时间: 2007-03-21 17:31
送出感谢: 0
接收感谢: 0

#2

帖子 bonjourworld » 2007-03-22 9:43

各位高手帮帮忙啊!!!
头像
avauntage
帖子: 570
注册时间: 2005-09-22 10:15
来自: 北京
送出感谢: 0
接收感谢: 0

#3

帖子 avauntage » 2007-03-22 9:54

罕见!
建议你不要用第三方的分区程序,用widowsxp的安装盘启动,删除所有分区,然后再分出两个分区给windows,比如第一个20G,第二个20G,其余的保持空闲分区状态。
将windows装在第一个分区上,将你自己的数据放在第二个分区上。
windows正常了之后,再空闲的硬盘上安装ubuntu。
空手把锄头,步行骑水牛;人在桥上过,人流水不流。
bonjourworld
帖子: 29
注册时间: 2007-03-21 17:31
送出感谢: 0
接收感谢: 0

#4

帖子 bonjourworld » 2007-03-22 10:34

多谢三楼的建议,不过我就是这么做的,还是一启动XP就蓝屏。
我的做法是:
1,删除所有分区,重新给区个XP,并留下一部分空间给U。
2,在XP的分区上安装XP。
3,XP装好后安装U,但是奇怪的是我在装U时看到一部分安装XP时未发现的磁盘空间,大概有3G多,我就将剩下的所有空间,包括XP没看到的那3G分给了U。
4,格式化U的分区,但是这次我没装U就直接重起。
5,启动XP,蓝屏!
6,我放入XP的盘再重起,本想修复XP,但XP安装盘检测硬盘的结果是所有分区都被合并为一个C盘,并且格式为未知!这时已经无法修复XP,只能全盘格式化重装。
7,在U的安装盘里也发现所有分区都没了,只有一个C盘,并且格式为未知,而且比XP看到的磁盘大3G仍然!
我第一次就是这样,数据都没了。这次还是这样。实在不知道问题出在哪里,我想反正已经付出了这么大的代价,说什么也要把两个系统装好!还希望各位高手多多帮忙啊!!
头像
cime63
帖子: 286
注册时间: 2007-01-28 11:53
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 cime63 » 2007-03-22 11:29

3,XP装好后安装U,但是奇怪的是我在装U时看到一部分安装XP时未发现的磁盘空间,大概有3G多,我就将剩下的所有空间,包括XP没看到的那3G分给了U。
==================================
LZ,你还是让机器自动选择空闲分区吧。不要乱搞。
bonjourworld
帖子: 29
注册时间: 2007-03-21 17:31
送出感谢: 0
接收感谢: 0

#6

帖子 bonjourworld » 2007-03-22 11:42

哦 我一直都手动的。 自动的会怎么分呢它??
头像
cime63
帖子: 286
注册时间: 2007-01-28 11:53
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 cime63 » 2007-03-22 12:00

不知道什么原因导致XP找不到部分空间,还是先不要动得好

我一直是ubuntu自动选择分区的,没有出现过XP不能启动的情况
oumengzhi
帖子: 31
注册时间: 2007-02-15 7:59
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 oumengzhi » 2007-03-22 13:39

我跟你说一下我的遭遇,和我解决的办法,或许对你有帮助
我电脑刚买,在电脑城那边他帮我GHOST了一个XP,然后我回家马上删了,装番茄花园,C盘分给系统,然后又分了D,E,F三个,都为NTFS,然后上网,下了ubuntu6.10-desktop,刻盘,然后光驱启动,运行install,那个partioner还是什么忘记了,识别出了我原来的分区,然后我从F那里割出30G,作为EXT3分区,然后又割出512M,作为swap,然后下一步,将所有盘都挂载上去了,那个30G的EXT3分区作为"/",512M作为SWAP,可是下一步的时候居然提示没有根文件系统,这时郁闷了,然后试了网上的很多方法,具体的就不废话了,都没效果,那天搞到半夜,都没装上,火大了,关机,睡觉,第二天起来后将整个盘全删了,然后分出一个10G的给XP安装,其余的放着不动,也没分区,然后装好XP后什么都没装,马上重启,光驱引导进ubuntu,然后install,分区这个地方分了一个30G的给EXT3,512M给SWAP,就这样,成功了,完成后再将剩余的一些分了区,到现在使用正常
这位XD可以参考一下,或许有帮助
bonjourworld
帖子: 29
注册时间: 2007-03-21 17:31
送出感谢: 0
接收感谢: 0

#9

帖子 bonjourworld » 2007-03-22 17:13

楼上的,你的方法我试过,不行我这。
但我发现我装好windows后只要不改变XP没有识别出来那3G的未知分区,XP就不会受影响。

那3G的分区是不是隐藏分区? 为什么这3Gubunbu能看到XP却看不到??而且我用了两个第三方的工具都没有发现这3G的空间!
这是为什么??
回复

回到 “老旧版本支持”