关于xfont-wqy的问题

为当前最终发行版之前的所有版本提供支持
回复
oopszj
帖子: 161
注册时间: 2006-03-03 19:16
送出感谢: 0
接收感谢: 0

关于xfont-wqy的问题

#1

帖子 oopszj » 2007-03-22 16:28

我用的是dapper

我记不清楚具体情况了,当时好像安装easywine的时候,他推荐安装xfont-wqy,我以为是wqy的一个版本,所以就安装了,第一安装的时候出错了,不过在接下来我第二次安装的时候给安装上了。

后来,又有源里的opera升级,我升级了,升级后发现,我的opera的菜单没有中文了(以前是),同时我输入网址时,敲入若干个字母后,就再也敲不进去了,到现在我一个网页都没上去过。
同时,我的gFTP连接到服务器后,文件名的中文显示也没了(以前是),我认为是xfont-wqy的问题,可是我卸载不了。

错误信息:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
下列软件包将被【卸载】:
xfonts-wqy
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 1 个软件包,有 0 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B 的软件包。
解压缩后将会空出 5116kB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 136077 个文件和目录。)
正在删除 xfonts-wqy ...
usage error: unrecognized option
Usage: update-fonts-dir DIRECTORY ...
update-fonts-dir { -h | --help }
This program is a wrapper for mkfontdir(1x) that is primarily useful to Debian
package maintainer scripts. See update-fonts-dir(Cool for more information.
Options:
-h, --help display this usage message and exitdpkg:处理 xfonts-wqy (--remove)时出错:
子进程·post-removal script·返回了错误号·2
在处理时有错误发生:
xfonts-wqy
E: Sub-process /usr/bin/dpkg returned an error code (1)



求大牛解答!
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 zhan » 2007-03-22 16:49

帮你把水区的那个帖子也移动过来了。

你的问题看来是打包的问题。
到 /var/lib/dpkg/info 中 找到一个叫做 xfonts-wqy.postrm 的文件,修改好后就可正常删除了。
修改的方法,简单一点 删除其中所有的内容。不过按照这个脚本的意思是删除之后要更新字体目录的
所以删除 xfonts-wqy 之后,手工执行一下 sudo fc-cache -fv 应该就可以了.
好运!
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
oopszj
帖子: 161
注册时间: 2006-03-03 19:16
送出感谢: 0
接收感谢: 0

#3

帖子 oopszj » 2007-03-23 22:34

谢谢楼上的,但是我用你的方法后还是卸载不了!
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 zhan » 2007-03-23 23:01

请贴出出错代码!
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
oopszj
帖子: 161
注册时间: 2006-03-03 19:16
送出感谢: 0
接收感谢: 0

#5

帖子 oopszj » 2007-03-29 13:49

正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
下列软件包将被【卸载】:
xfonts-wqy
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 1 个软件包,有 21 个软件未被升 级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B 的软件包。
解压缩后将会空出 5116kB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 136077 个文件和目录。)
正在删除 xfonts-wqy ...
dpkg (子进程):无法运行 post-removal script: Exec format error
dpkg:处理 xfonts-wqy (--remove)时出错:
子进程·post-removal script·返回了错误号·2
在处理时有错误发生:
xfonts-wqy
E: Sub-process /usr/bin/dpkg returned an error code (1)
oopszj
帖子: 161
注册时间: 2006-03-03 19:16
送出感谢: 0
接收感谢: 0

#6

帖子 oopszj » 2007-03-30 10:36

我自己顶一下吧!
gzd900
帖子: 176
注册时间: 2005-12-14 4:37
来自: 十堰
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 gzd900 » 2007-03-30 16:38

如果你安装的输入法是SCIM,那就可能是和这个有冲突。不过我不敢肯定,你可以先卸载SCIM输入法试试看。
oopszj
帖子: 161
注册时间: 2006-03-03 19:16
送出感谢: 0
接收感谢: 0

#8

帖子 oopszj » 2007-04-01 11:03

谢谢楼上的。
我还是希望有人能给出肯定的答案!
oopszj
帖子: 161
注册时间: 2006-03-03 19:16
送出感谢: 0
接收感谢: 0

#9

帖子 oopszj » 2007-04-02 16:11

自己顶一下!
oopszj
帖子: 161
注册时间: 2006-03-03 19:16
送出感谢: 0
接收感谢: 0

#10

帖子 oopszj » 2007-04-11 18:41

再顶
sunzhaoyu2000
帖子: 700
注册时间: 2006-10-18 15:48
送出感谢: 0
接收感谢: 0

#11

帖子 sunzhaoyu2000 » 2007-08-23 11:14

zhan 写了:帮你把水区的那个帖子也移动过来了。

你的问题看来是打包的问题。
到 /var/lib/dpkg/info 中 找到一个叫做 xfonts-wqy.postrm 的文件,修改好后就可正常删除了。
修改的方法,简单一点 删除其中所有的内容。不过按照这个脚本的意思是删除之后要更新字体目录的
所以删除 xfonts-wqy 之后,手工执行一下 sudo fc-cache -fv 应该就可以了.
好运!



楼上的,我按照此法成功了哈哈华
回复

回到 “老旧版本支持”