各位精通LINUX的兄弟,帮我看看这是怎么回事啊? 为盼!

为当前最终发行版之前的所有版本提供支持
回复
atht520
帖子: 1
注册时间: 2007-03-20 10:59
送出感谢: 0
接收感谢: 0

各位精通LINUX的兄弟,帮我看看这是怎么回事啊? 为盼!

#1

帖子 atht520 » 2007-03-23 11:55

tuhongtao@tuhongtao-laptop:~$ sudo apt-get install linux-headers-$(uname -r) build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
linux-headers-2.6.17-11-generic 已经是最新的版本了。
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.0) 但是它将不会被安装
E: 无法安装的软件包

各位精通LINUX的兄弟,帮我看看这是怎么回事啊? 为盼!
头像
hualang0929
帖子: 1226
注册时间: 2006-11-11 10:23
来自: Mars
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 hualang0929 » 2007-03-23 12:35

试试 apt-get -f install 或者aptitude install
抬头望星空一片晴,我独行,夜已渐寒……
chinese_ys
帖子: 116
注册时间: 2006-11-03 8:49
来自: Halifax
送出感谢: 0
接收感谢: 0

#3

帖子 chinese_ys » 2007-03-23 12:55

就用build-essentials就可以了
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#4

帖子 dogfox » 2007-03-23 12:56

已经是系统默认的最新内核了
毋需再次更新
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 SuperWar3Fan » 2007-03-23 15:00

更改一下源。
有空的话,请访问我的BlogUbuntu高地
回复

回到 “老旧版本支持”