当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 诡异:音箱无声耳麦有声……
帖子发表于 : 2007-03-23 12:40 

注册: 2007-03-23 12:08
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
发现耳麦可以出声音,但是不知道为什么音箱放不出声音。
用的是富士通的s7021系列,有人说是声卡问题,wingdows下没问题。
请高手指点,谢谢啦~


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-03-23 15:01 
头像

注册: 2006-05-20 6:25
帖子: 1263
地址: 山东淄博
送出感谢: 0 次
接收感谢: 0 次
应该是硬件问题!
音量不够?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-03-23 15:28 

注册: 2007-02-13 15:24
帖子: 1485
地址: 地球
送出感谢: 0 次
接收感谢: 0 次
在 Wiki 搜索混音。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-03-23 15:37 

注册: 2007-02-13 15:24
帖子: 1485
地址: 地球
送出感谢: 0 次
接收感谢: 0 次
靠!Wiki改版了,以前那个混音的链接改了。帮你找过来。

* 为什么我在同时打开两个应用程序时不能听到声音呢? 大多数Linux初学者都遇到这样一个问题:“为什么我在同时打开两个应用程序时不能听到声音呢?”这是因为你的声卡需要“软混音”。值得庆幸的是,ALSA提供了这项功能,这

使得解决这个问题并不是很难。 首先需要安装libesd-alsa0,它就在Ubuntu官方软件库中。

代码:
sudo apt-get install libesd-alsa0



然后,用sudo gedit或您喜欢的文本编辑器创建文件/etc/asound.conf(请确定您使用了sudo,因为您需要root权限):

代码:
sudo gedit /etc/asound.conf



输入一下内容并保持关闭。

代码:
 pcm.card0 {
   type hw
   card 0
 }

 pcm.!default {
   type plug
   slave.pcm "dmixer"
 }

 pcm.dmixer {
   type dmix
   ipc_key 1025
   slave {
     pcm "hw:0,0"
     period_time 0
     period_size 1024
     buffer_size 4096
     periods 128
     rate 44100
   }
   bindings {
     0 0
     1 1
   }
 }
 


(上面的文件可以在大多数声卡上正常运行…尽管我成功地测试了三个不同的声卡,但我还是不能确保它可以使所有声卡都能正常运行)

* 接下来,运行

代码:
sudo gedit /etc/esound/esd.conf



,将文件改成下面的内容:

代码:
[esd]
 auto_spawn=1
 spawn_options=-terminate -nobeeps -as 2 -d default
 spawn_wait_ms=100
 # default options are used in spawned and non-spawned mode
 default_options=
 



然后打开您的Gnome声音控制面板并启用声音服务器,接着到多媒体系统选择控制面板,将其设成ALSA或ESD,并重启计算机。 接下来您就可以将应用程序设成使用ALSA或ESD,这样您就可以一次听到多个声音了。就算是玩着用ALSA发音的游戏并听到使用ESD的GNOME应用发出的声音也没有任何问题! 有些朋友在hoary上按照上述的方法设置却遇到了问题,他们不能在mozilla/firefox/epiphany程序中听到声音,结果我发现在启动 firefox时,程序查找libesd.so.1而系统却只有libesd.so.0,所以只要运行命令

代码:
sudo ln -s /usr/lib/libesd.so.0 /usr/lib/libesd.so.1



后就可以解决这个问题了


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-03-23 17:50 
头像

注册: 2006-09-02 14:18
帖子: 5308
地址: 汉桑城
送出感谢: 1
接收感谢: 1
applnk 写道:
靠!Wiki改版了,以前那个混音的链接改了。帮你找过来。

* 为什么我在同时打开两个应用程序时不能听到声音呢? 大多数Linux初学者都遇到这样一个问题:“为什么我在同时打开两个应用程序时不能听到声音呢?”这是因为你的声卡需要“软混音”。值得庆幸的是,ALSA提供了这项功能,这

使得解决这个问题并不是很难。 首先需要安装libesd-alsa0,它就在Ubuntu官方软件库中。

代码:
sudo apt-get install libesd-alsa0



然后,用sudo gedit或您喜欢的文本编辑器创建文件/etc/asound.conf(请确定您使用了sudo,因为您需要root权限):

代码:
sudo gedit /etc/asound.conf



输入一下内容并保持关闭。

代码:
 pcm.card0 {
   type hw
   card 0
 }

 pcm.!default {
   type plug
   slave.pcm "dmixer"
 }

 pcm.dmixer {
   type dmix
   ipc_key 1025
   slave {
     pcm "hw:0,0"
     period_time 0
     period_size 1024
     buffer_size 4096
     periods 128
     rate 44100
   }
   bindings {
     0 0
     1 1
   }
 }
 


(上面的文件可以在大多数声卡上正常运行…尽管我成功地测试了三个不同的声卡,但我还是不能确保它可以使所有声卡都能正常运行)

* 接下来,运行

代码:
sudo gedit /etc/esound/esd.conf



,将文件改成下面的内容:

代码:
[esd]
 auto_spawn=1
 spawn_options=-terminate -nobeeps -as 2 -d default
 spawn_wait_ms=100
 # default options are used in spawned and non-spawned mode
 default_options=
 



然后打开您的Gnome声音控制面板并启用声音服务器,接着到多媒体系统选择控制面板,将其设成ALSA或ESD,并重启计算机。 接下来您就可以将应用程序设成使用ALSA或ESD,这样您就可以一次听到多个声音了。就算是玩着用ALSA发音的游戏并听到使用ESD的GNOME应用发出的声音也没有任何问题! 有些朋友在hoary上按照上述的方法设置却遇到了问题,他们不能在mozilla/firefox/epiphany程序中听到声音,结果我发现在启动 firefox时,程序查找libesd.so.1而系统却只有libesd.so.0,所以只要运行命令

代码:
sudo ln -s /usr/lib/libesd.so.0 /usr/lib/libesd.so.1



后就可以解决这个问题了
wiki有搜索功能的.... :em26 :em25 :em88


_________________
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译