[问题]用源文件安装basket遇到问题

为当前最终发行版之前的所有版本提供支持
回复
democracia
帖子: 29
注册时间: 2007-02-05 15:54
送出感谢: 0
接收感谢: 0

[问题]用源文件安装basket遇到问题

#1

帖子 democracia » 2007-03-24 22:39

非常喜欢basket这个软件,源中已经有了它的1。0版了。最近它出了新版,修正了几个问题,增加了中文版,我很想安装。可是下载source后,一直无法正确安装,表现是:./configure之后,提示

checking for Qt... configure: error: Qt (>= Qt 3.0 and < 4.0) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!

在这之前也提示少什么东西,都用新立德给安装上了,于是先前几步无法进行的也可以进行下来了,只是到了这个缺少QT的提示后,就不知道该下载什么了。找到了几乎所有和QT有关的都给下载了,还是有上述提示,这该怎么解决啊?
我不想等到源中有了1.01的版本再下载,毕竟也要学会使用源文件安装啊。
多谢了各位!
头像
FFFrog
帖子: 621
注册时间: 2006-05-12 23:28
来自: 江西乐平
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 FFFrog » 2007-03-24 22:56

Basket自带了一个编译安装程序:

代码: 全选

./installer
试试官网上的方法:If the process does not succeed or some libraries are missing or cannot be found, try to install the *-dev or *-devel packages of your distribution: they contain library (X, QT, KDE...) sources needed to compile from sources.

另外1.01 在 www.getdeb.net 上有.deb包。
democracia
帖子: 29
注册时间: 2007-02-05 15:54
送出感谢: 0
接收感谢: 0

搞定了,非常感谢!

#3

帖子 democracia » 2007-03-25 11:07

官网的方法我也看了,也尝试下载了很多相关的包,还是搞不定.
但是在getdeb上找到了新版!安装的时候又在网上下载了20个包,然后就可以使用了!非常感谢FFFrog!
回复

回到 “老旧版本支持”