[问题]在新立得里如何安装gcc和g++?

为当前最终发行版之前的所有版本提供支持
tao17388
帖子: 27
注册时间: 2007-02-11 20:42
送出感谢: 0
接收感谢: 0

[问题]在新立得里如何安装gcc和g++?

#1

帖子 tao17388 » 2007-03-25 13:48

我用新立得搜索gcc和g++得出很多文件,想要安装gcc和g++应该安装哪些文件?另外如何安装java?
先谢过了~~~~~~~~
上次由 tao17388 在 2007-03-25 13:52,总共编辑 1 次。
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2007-03-25 13:50

gcc/g++

sudo apt-get build-essential
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
hualang0929
帖子: 1226
注册时间: 2006-11-11 10:23
来自: Mars
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 hualang0929 » 2007-03-25 13:51

wiki
抬头望星空一片晴,我独行,夜已渐寒……
binsir543
帖子: 180
注册时间: 2007-03-22 2:04
送出感谢: 0
接收感谢: 0

#4

帖子 binsir543 » 2007-03-25 13:53

这么搜的话可能要全装吧,你就sudo apt-get install gcc g++不就行了
tao17388
帖子: 27
注册时间: 2007-02-11 20:42
送出感谢: 0
接收感谢: 0

#5

帖子 tao17388 » 2007-03-25 13:56

那java如何安装呢,不知道ubuntu自带了java没有?
binsir543
帖子: 180
注册时间: 2007-03-22 2:04
送出感谢: 0
接收感谢: 0

#6

帖子 binsir543 » 2007-03-25 14:02

第一步:

sudo apt-get install sun-java5-jdk
安装完毕之后,选择默认 java:
sudo update-alternatives --config java
然后配置环境变量:
sudo vim /etc/environment
在其中添加如下两行:
CLASSPATH=/usr/lib/jvm/java-1.5.0-sun/lib
JAVA_HOME=/usr/lib/jvm/java-1.5.0-sun
izee
帖子: 661
注册时间: 2007-01-26 13:38
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 izee » 2007-03-25 14:08

有java6
tao17388
帖子: 27
注册时间: 2007-02-11 20:42
送出感谢: 0
接收感谢: 0

#8

帖子 tao17388 » 2007-03-25 22:58

问题没有全部解决,我自己顶一下。如题gcc已经安装成功,但是安装g++的时候遇到如下问题:
在新立得里面搜索, 搜索到g++作标记时出现如下提示:

g++:
依赖: g++-4.0 但是此软件包将不会被安装

搜索到g++-4.0后要标记的时候又提示如下:
g++-4.0:
依赖: libstdc++6-4.0-dev 但是此软件包将不会被安装


然后我搜索libstdc++6-4.0-dev,标记的时候提示如下:
libstdc++6-4.0-dev:
依赖: g++-4.0 但是此软件包将不会被安装
依赖: libc6-dev 但是此软件包将不会被安装

搜索到libc6-dev,标记的时候提示又如下:libc6-dev:
依赖: libc6 (=2.3.6-0ubuntu20.4) 但是将会安装 2.4-1ubuntu12。 根本无法安装g++.

另外,六楼提到的安装java的方法:
第一步:

sudo apt-get install sun-java5-jdk
安装完毕之后,选择默认 java:
sudo update-alternatives --config java
然后配置环境变量:
sudo vim /etc/environment
在其中添加如下两行:
CLASSPATH=/usr/lib/jvm/java-1.5.0-sun/lib
JAVA_HOME=/usr/lib/jvm/java-1.5.0-sun


我做到“在其中添加如下两行:
CLASSPATH=/usr/lib/jvm/java-1.5.0-sun/lib
JAVA_HOME=/usr/lib/jvm/java-1.5.0-sun”这一步时出现如下画面,不知道应该在何处添加上面提到的两行代码和如何在添加代码后保存退出(清大家教教我,谢谢!):

PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games"
LANG="zh_CN.UTF-8"
LANGUAGE="zh_CN:zh:en_US:en"
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
dsyin
帖子: 116
注册时间: 2006-03-08 22:20
送出感谢: 0
接收感谢: 0

#9

帖子 dsyin » 2007-03-25 23:23

按 Esc, 然后按 :wq 存盘退出。
或者改用 nano
试试用二楼的方法来装g++
tao17388
帖子: 27
注册时间: 2007-02-11 20:42
送出感谢: 0
接收感谢: 0

#10

帖子 tao17388 » 2007-03-25 23:57

用2楼的方法安装gcc/g++的时候,出现如下提示:
tao@tao-desktop:~$ sudo apt-get build-essential
Password:
E: 无效的操作 build-essential
g++依然无法安装.
头像
goldfox_79
帖子: 1937
注册时间: 2005-10-16 8:26
来自: 地球
送出感谢: 0
接收感谢: 1 次
联系:

#11

帖子 goldfox_79 » 2007-03-26 0:46

tao17388 写了:用2楼的方法安装gcc/g++的时候,出现如下提示:
tao@tao-desktop:~$ sudo apt-get build-essential
Password:
E: 无效的操作 build-essential
g++依然无法安装.


应该是
$sudo apt-get install build-essential
头像
shaojz2005
帖子: 278
注册时间: 2006-07-13 13:01
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 shaojz2005 » 2007-03-26 1:02

代码: 全选

 sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
Reading state information... 完成     
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  build-essential: 依赖: libc6-dev 但是它将不会被安装 或
                           libc-dev
                   依赖: g++ (>= 4:4.1.1) 但是它将不会被安装
E: 无法安装的软件包


还是不行……
头像
goldfox_79
帖子: 1937
注册时间: 2005-10-16 8:26
来自: 地球
送出感谢: 0
接收感谢: 1 次
联系:

#13

帖子 goldfox_79 » 2007-03-26 1:03

检查source.list是否设置正确
tao17388
帖子: 27
注册时间: 2007-02-11 20:42
送出感谢: 0
接收感谢: 0

#14

帖子 tao17388 » 2007-03-26 12:23

我用11楼的方法还是装不上,运行结果如下(另外我用的源是http://debian.ustc.edu.cn/ubuntu/和http://ubuntu.cn99.com/ubuntu/,前面升级和安装其他软件的时候都没有问题):

tao@tao-desktop:~$ sudo apt-get install build-essential
正在读取软件包列表... 有错误!
E: Dynamic MMap ran out of room
E: 处理 slang-gtk (NewVersion1)时出错
E: Problem with MergeList /var/lib/apt/lists/debian.ustc.edu.cn_ubuntu_dists_feisty_universe_binary-i386_Packages
E: 无法解析或打开软件包的列表或是状态文件。

请指教
gmlbh
帖子: 406
注册时间: 2006-03-21 10:47
送出感谢: 0
接收感谢: 0

#15

帖子 gmlbh » 2007-03-26 13:16

其实也不用在终端上敲命令的,进入新立得,reload一下,系统会自动搜索源里面有什么软件得,然后选中要安装得软件,再apply,就会自动帮你下载安装了得。如果源出错或者联不上,系统会提示得。你要得GCC和G++,安装了build-essential的时候系统会自动把关联的都装上的。
回复

回到 “老旧版本支持”