怎么 解决笔记本电脑带上耳机有声音。拿掉耳机本本的喇叭不发声的问题阿??

为当前最终发行版之前的所有版本提供支持
回复
最终完美体
帖子: 170
注册时间: 2007-03-17 15:30
送出感谢: 0
接收感谢: 0
联系:

怎么 解决笔记本电脑带上耳机有声音。拿掉耳机本本的喇叭不发声的问题阿??

#1

帖子 最终完美体 » 2007-03-25 15:34

以前我的本本是从来不发声。/今天看到有位大哥说-----

方法很简单,打开音量控制,找到External Amplifier开关,让其显示出来。

如果这个后面的对号是选中的,把对号去掉。


按照他的方法。我的本本带上耳机,彻底有声音了。而且很大。但是把耳机拿掉。本本的喇叭没有声音。有哪位大哥知道这样自的问题该怎么解决么?
Besson
帖子: 13
注册时间: 2007-04-18 11:02
送出感谢: 0
接收感谢: 0

#2

帖子 Besson » 2007-05-19 15:26

解决ubuntu在笔记本上外置扬声器不出声的问题

Cheers! 成功解决了ubuntu在我的 Benq Joybook 7000 上面外置扬声器不出声的问题。我一直以为是与modules有关呢,实际上解决的方法非常简单,感谢ubuntu论坛的icomes

Solution - Benq joybook 7000 external speaker doesn't work on ubuntu (may work for other laptops)

首先,打开音量控制。
(Open volume control panel)

选择“文件”-“更改设备”-“Intel 82801DB-ICH4 (Alsa Mixer)"
Select "File" - "Device" - "Intel 82801DB-DB-ICH4 (Alsa Mixer)"

选择“编辑”-“首选项”
Select "Edit" - "Preference"

为了让外置扬声器发声,出了已经选择上的选项,还要确保选择上以下几项:
(Ensure the following options are marked.)

Master Surround
PCM
Surround Jack Mode
Spread Front to Surround and Center/LFE
Channel Mode

其中,在“回放”中,保证Master, Master Surround,PCM处于非静音状态
In "Playback",Unmute "Master" "Master Surround" "PCM"
在“开关”中,打开Spread Front to Surround and Center/LFE
In "Toggle", Mark "Spread Front to Surround and Center/LFE"
在“选项”中,Surround Jack Mode 选择 Shared,Channel Mode选择4ch或者6ch
In "Option" Choose "Shared" in Surround Jack Mode
Choose "4ch" or "6ch" in Channel Mode

Enjoy!

据icomes说,这个问题好像不只是在Benq的机器上面出现,其他品牌的笔记本也有可能出现。
好好享受ubuntu的音乐之旅吧!

P.S 我以前这个问题没有在Google上面找到,也不知是为什么。所以在自己的文章里面加上英文注解,方便遇到同样问题的世界朋友。

Tags: ubuntu benq joybook linux external speaker does not work

Trackback: http://tb.donews.net/TrackBack.aspx?PostId=910665
nbdxkfq
帖子: 144
注册时间: 2007-01-10 23:56
送出感谢: 0
接收感谢: 0

#3

帖子 nbdxkfq » 2007-10-21 19:27

可是我找不到Surround Jack Mode ,怎么办阿?
回复

回到 “老旧版本支持”