关于依赖的问题

为当前最终发行版之前的所有版本提供支持
回复
头像
shaojz2005
帖子: 278
注册时间: 2006-07-13 13:01
送出感谢: 0
接收感谢: 0
联系:

关于依赖的问题

#1

帖子 shaojz2005 » 2007-03-26 0:57

有时安装一些软件,会显示“该软件依赖xxx软件,但是它不会被安装“,对此十分迷惑不解。apt技术不是可以解决依赖性问题吗,为什么还会出现这样的错误。如果继续安装它提示的没有安装的那个包,系统又会继续提示其它包缺失了,没完没了。请问这是什么原因造成的,如何解决?
头像
goldfox_79
帖子: 1937
注册时间: 2005-10-16 8:26
来自: 地球
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 goldfox_79 » 2007-03-26 1:04

以前遇到过source.list设置不正确,比如6.10的系统却用了6.06的源,试图安装时就出现这样的错误
applnk
帖子: 1485
注册时间: 2007-02-13 15:24
来自: 地球
送出感谢: 0
接收感谢: 0

#3

帖子 applnk » 2007-03-26 1:56

楼主的头像是自己改的吗?好像把动态改消失。
图片
图片
binsir543
帖子: 180
注册时间: 2007-03-22 2:04
送出感谢: 0
接收感谢: 0

#4

帖子 binsir543 » 2007-03-26 5:43

同意二楼,正常来说既然放到源里面,一般就不会出现依赖问题,除非服务器出问题了,有些地址你访问不到
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#5

帖子 eexpress » 2007-03-26 7:34

用aptitude吧
不被安装,还有可能是你hold/keep了某些包。你不允许某些包升级,导致关联的包不能动。
通常是源里面少了包。
● 鸣学
gegfried
帖子: 482
注册时间: 2006-06-29 17:30
送出感谢: 0
接收感谢: 0

#6

帖子 gegfried » 2007-03-26 8:18

遇到这样的错误改一下源的设置就好了,我有一次安装wine,居然叫我安装一大堆用不到的东东,还是更改源才弄好的。。
回复

回到 “老旧版本支持”