如何在ubuntu中安装VMD?

为当前最终发行版之前的所有版本提供支持
回复
jacksonguo
帖子: 2
注册时间: 2007-03-26 21:10
送出感谢: 0
接收感谢: 0

如何在ubuntu中安装VMD?

#1

帖子 jacksonguo » 2007-03-26 21:22

我要安装VMD(visual Molecular Dynamics)软件,安装程序如下:
root@gyh-desktop:/home/gyh# cd Desktop/
root@gyh-desktop:/home/gyh/Desktop# ls
vmd-1.8.5 vmd-1.8.5.bin.LINUX.opengl.tar.gz
root@gyh-desktop:/home/gyh/Desktop# cd vmd-1.8.5
root@gyh-desktop:/home/gyh/Desktop/vmd-1.8.5# ls
Announcement configure.options doc LINUX proteins scripts
bin data lib msvc python shaders
configure distrib LICENSE plugins README src
root@gyh-desktop:/home/gyh/Desktop/vmd-1.8.5# sudo apt-get install build-essential csh
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
build-essential 已经是最新的版本了。
csh 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
root@gyh-desktop:/home/gyh/Desktop/vmd-1.8.5# ./configure
using configure.options: LINUX OPENGL FLTK TK ACTC IMD SPACEBALL LIBTACHYON VRPN NETCDF TCL PYTHON PTHREADS NUMPY SILENT
下边该如何安装?为何./configure以后出现using configure.options: LINUX OPENGL FLTK TK ACTC IMD SPACEBALL LIBTACHYON VRPN NETCDF TCL PYTHON PTHREADS NUMPY SILENT,下一步该怎马办?
谢谢了
头像
roylez
论坛版主
帖子: 1928
注册时间: 2005-10-04 10:59
来自: 上海
送出感谢: 0
接收感谢: 1 次

#2

帖子 roylez » 2007-03-27 0:57

难得在这里遇到一个同行……

vmd我没有在linux下用过,主要是安装麻烦。在windows下试过,感觉奇奇怪怪的,也放弃了。现在我主要用的molecular modeling软件是pymol,用python写的,稍微有些慢(我的原子数目在3万左右,是金属,如果你主要用来画protein,也许会快很多),但是安装极为方便,解压缩就行。pymol最大的好处就是制作动画方便,直接打开multi-model pdb就可以看了,选择好合适的视角,就可以很快导出图片。

如果你和我一样是做金属的,或者是做硅之类的原子晶体,比较快的modeling软件还有Ohio州立大学Li Ju写的atomeye。因为是用c写的而且算法上面做了调整(Li Ju的数学功底实在是太好了,atomeye的manual里面大部分的公式我都看不懂),速度飞快,但是缺点就是要记一些快捷键。

说了半天,好像还是没帮上你的忙 :em27
弄个dropbox空间来备份文件或者做私人代码服务器
配置:[url]git://github.com/roylez/dotfiles.git[/url]
主页:http://roylez.heroku.com
各种稀奇玩意儿:http://dooloo.info
jacksonguo
帖子: 2
注册时间: 2007-03-26 21:10
送出感谢: 0
接收感谢: 0

感谢

#3

帖子 jacksonguo » 2007-03-27 17:30

感谢你的回帖,不过我想知道的是如何安装VMD(ubuntu),以后可以在分子动力学方面和你交流一下。
再次感谢你的kind
头像
roylez
论坛版主
帖子: 1928
注册时间: 2005-10-04 10:59
来自: 上海
送出感谢: 0
接收感谢: 1 次

#4

帖子 roylez » 2007-03-28 0:59

如果我没猜错,doc 是个目录,在里面看看没有安装帮助。

configure.options是编译时候选择的参数。我觉得你上面那些参数应该是可以的,但是不知道你安装了numpy没有。我用的是dapper,没有numpy,只有numarray和Numeric;如果你用的是edgy或者更新的版本,可以用apt-get安装numpy。
弄个dropbox空间来备份文件或者做私人代码服务器
配置:[url]git://github.com/roylez/dotfiles.git[/url]
主页:http://roylez.heroku.com
各种稀奇玩意儿:http://dooloo.info
sunny1984218
帖子: 2
注册时间: 2008-09-05 14:15
送出感谢: 0
接收感谢: 0

求助VMD 安装说明

#5

帖子 sunny1984218 » 2008-09-05 14:21

我现在也要安装VMD, 也遇到了和你同样的问题,请给点安装信息好吗?谢谢!
wikaiqi
帖子: 1
注册时间: 2008-05-02 20:46
送出感谢: 0
接收感谢: 0

Re: 求助VMD 安装说明

#6

帖子 wikaiqi » 2008-09-09 10:25

我最近安装成功了,您可以试试:
1. Download the VMD for linux code form http://www.ks.uiuc.edu/Development/Down ... wnload.cgi
2. Extracting the VMD source. This will produce a subdirectory named vmd-1.8.6. Thus, cd there.
3. ./configure LINUX.
4. cd src.
5. sudo make Install
6. But before using the VMD, Please do this : sudo apt-get install csh.


sunny1984218 写了:我现在也要安装VMD, 也遇到了和你同样的问题,请给点安装信息好吗?谢谢!
packsackao
帖子: 1
注册时间: 2008-12-26 19:29
送出感谢: 0
接收感谢: 0

Re: 求助VMD 安装说明

#7

帖子 packsackao » 2008-12-26 19:32

补充:视个人环境安装情况也许运行前还要 sudo apt-get install libstdc++5
wikaiqi 写了:我最近安装成功了,您可以试试:
1. Download the VMD for linux code form http://www.ks.uiuc.edu/Development/Down ... wnload.cgi
2. Extracting the VMD source. This will produce a subdirectory named vmd-1.8.6. Thus, cd there.
3. ./configure LINUX.
4. cd src.
5. sudo make Install
6. But before using the VMD, Please do this : sudo apt-get install csh.


sunny1984218 写了:我现在也要安装VMD, 也遇到了和你同样的问题,请给点安装信息好吗?谢谢!
回复

回到 “老旧版本支持”