apt-get update更新软件源问题

为当前最终发行版之前的所有版本提供支持
回复
applee
帖子: 4
注册时间: 2007-03-27 15:30
送出感谢: 0
接收感谢: 0

apt-get update更新软件源问题

#1

帖子 applee » 2007-03-27 15:34

我是局域网内通过http代理上网 而且代理还要验证用户名密码
我已经在apt.conf里添加了Aquire::http::proxy"代理地址:端口"
问题是 代理要验证的用户名密码怎么添加? http协议和ftp那种一样吗?
username:password@address:port这样好像不行
binsir543
帖子: 180
注册时间: 2007-03-22 2:04
送出感谢: 0
接收感谢: 0

#2

帖子 binsir543 » 2007-03-27 15:41

export http_proxy="http://user:passwd@IP:port"
applee
帖子: 4
注册时间: 2007-03-27 15:30
送出感谢: 0
接收感谢: 0

#3

帖子 applee » 2007-03-27 15:52

6.10的源哪个比较快?我是北京网通的
我还是连接不上
407 Proxy Authentication Required ( The ISA Server requires authorization to fulfill the request. Access to the Web Proxy service is denied
user:password@ip:port这个格式不对吧? 否则应该能连上代理的 因为我浏览器能用代理的 firefox里也只能设置代理ip端口 没法设置口令密码阿 每次都每次都弹出对话框验证。
binsir543
帖子: 180
注册时间: 2007-03-22 2:04
送出感谢: 0
接收感谢: 0

#4

帖子 binsir543 » 2007-03-27 16:27

apt-get是用环境变量http_proxy或ftp_proxy来设定代理服务器类型地址和端口

环境变量可以在/root/.profile里面设定,在.profile最后增加4行:
ftp_proxy=http://user:passwd@IP:port
export ftp_proxy
http_proxy=http://user:passwd@IP:port
export http_proxy
回复

回到 “老旧版本支持”