Help!!

为当前最终发行版之前的所有版本提供支持
回复
ashunter
帖子: 202
注册时间: 2007-02-03 2:46
送出感谢: 0
接收感谢: 0

Help!!

#1

帖子 ashunter » 2007-03-27 16:25

Who can help me?I can get in the Gnone,but there are some problems ...
ashunter@ashunter-laptop:~$ sudo apt-get upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 7 个软件包没有被完全安装或卸载。
需要下载 0B 的软件包。
解压缩后会消耗掉 0B 的额外空间。
您希望继续执行吗?[Y/n]y
正在设置 gdm (2.18.0-0ubuntu3) ...
* Reloading GNOME Display Manager configuration... * Changes will take effect when all current X sessions have ended.
[ OK ]
dpkg:处理 gdm (--configure)时出错:
子进程·post-installation script·返回了错误号·139
dpkg:依赖关系问题使得 fast-user-switch-applet 的配置工作不能继续:
fast-user-switch-applet 依赖于 gdm;然而:
软件包 gdm 还没有被配置。
dpkg:处理 fast-user-switch-applet (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 gdm-themes 的配置工作不能继续:
gdm-themes 依赖于 gdm (>> 2.4);然而:
软件包 gdm 还没有被配置。
dpkg:处理 gdm-themes (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 gnome-user-guide (2.18.0-0ubuntu1) ...
dpkg:处理 gnome-user-guide (--configure)时出错:
子进程·post-installation script·返回了错误号·139
dpkg:依赖关系问题使得 gnome-desktop-environment 的配置工作不能继续:
gnome-desktop-environment 依赖于 gdm (>= 2.14.5);然而:
软件包 gdm 还没有被配置。
gnome-desktop-environment 依赖于 fast-user-switch-applet (>= 2.14.2);然而:
软件包 fast-user-switch-applet 还没有被配置。
gnome-desktop-environment 依赖于 gnome-user-guide (>= 2.14);然而:
软件包 gnome-user-guide 还没有被配置。
dpkg:处理 gnome-desktop-environment (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 gnome 的配置工作不能继续:
gnome 依赖于 gnome-desktop-environment (= 1:2.14.3.3ubuntu1);然而:
软件包 gnome-desktop-environment 还没有被配置。
gnome 依赖于 gdm-themes;然而:
软件包 gdm-themes 还没有被配置。
dpkg:处理 gnome (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 ubuntu-docs 的配置工作不能继续:
ubuntu-docs 依赖于 gnome-user-guide;然而:
软件包 gnome-user-guide 还没有被配置。
dpkg:处理 ubuntu-docs (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
gdm
fast-user-switch-applet
gdm-themes
gnome-user-guide
gnome-desktop-environment
gnome
ubuntu-docs
E: Sub-process /usr/bin/dpkg returned an error code (1)
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#2

帖子 xiehuoli » 2007-03-27 16:30

sudo apt-get - -force -yes install
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
ashunter
帖子: 202
注册时间: 2007-02-03 2:46
送出感谢: 0
接收感谢: 0

#3

帖子 ashunter » 2007-03-27 16:42

~$ sudo apt-get - -force -yes install
E: 选项 -force:配置项后必须包含有形如“=<变量>”的具体指定
- -!
ashunter
帖子: 202
注册时间: 2007-02-03 2:46
送出感谢: 0
接收感谢: 0

It doesn't work!!!

#4

帖子 ashunter » 2007-03-27 16:46

ashunter@ashunter-laptop:~$ sudo apt-get --force-yes install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 7 个软件包没有被完全安装或卸载。
需要下载 0B 的软件包。
解压缩后会消耗掉 0B 的额外空间。
正在设置 gdm (2.18.0-0ubuntu3) ...
* Reloading GNOME Display Manager configuration... * Changes will take effect when all current X sessions have ended.
[ OK ]
dpkg:处理 gdm (--configure)时出错:
子进程·post-installation script·返回了错误号·139
dpkg:依赖关系问题使得 fast-user-switch-applet 的配置工作不能继续:
fast-user-switch-applet 依赖于 gdm;然而:
软件包 gdm 还没有被配置。
dpkg:处理 fast-user-switch-applet (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 gdm-themes 的配置工作不能继续:
gdm-themes 依赖于 gdm (>> 2.4);然而:
软件包 gdm 还没有被配置。
dpkg:处理 gdm-themes (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 gnome-user-guide (2.18.0-0ubuntu1) ...
dpkg:处理 gnome-user-guide (--configure)时出错:
子进程·post-installation script·返回了错误号·139
dpkg:依赖关系问题使得 gnome-desktop-environment 的配置工作不能继续:
gnome-desktop-environment 依赖于 gdm (>= 2.14.5);然而:
软件包 gdm 还没有被配置。
gnome-desktop-environment 依赖于 fast-user-switch-applet (>= 2.14.2);然而:
软件包 fast-user-switch-applet 还没有被配置。
gnome-desktop-environment 依赖于 gnome-user-guide (>= 2.14);然而:
软件包 gnome-user-guide 还没有被配置。
dpkg:处理 gnome-desktop-environment (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 gnome 的配置工作不能继续:
gnome 依赖于 gnome-desktop-environment (= 1:2.14.3.3ubuntu1);然而:
软件包 gnome-desktop-environment 还没有被配置。
gnome 依赖于 gdm-themes;然而:
软件包 gdm-themes 还没有被配置。
dpkg:处理 gnome (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 ubuntu-docs 的配置工作不能继续:
ubuntu-docs 依赖于 gnome-user-guide;然而:
软件包 gnome-user-guide 还没有被配置。
dpkg:处理 ubuntu-docs (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
gdm
fast-user-switch-applet
gdm-themes
gnome-user-guide
gnome-desktop-environment
gnome
ubuntu-docs
E: Sub-process /usr/bin/dpkg returned an error code (1)
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#5

帖子 xiehuoli » 2007-03-27 17:13

你先单独安装或者删除以上的那些包呢?
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
ashunter
帖子: 202
注册时间: 2007-02-03 2:46
送出感谢: 0
接收感谢: 0

#6

帖子 ashunter » 2007-03-27 17:18

ashunter@ashunter-laptop:~$ sudo apt-get remove ubuntu-docs
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
下列软件包将被【卸载】:
gnome2-user-guide ubuntu-docs
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 2 个软件包,有 0 个软件未被升级。
有 8 个软件包没有被完全安装或卸载。
需要下载 0B 的软件包。
解压缩后将会空出 18.8MB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 112137 个文件和目录。)
正在删除 gnome2-user-guide ...
Segmentation fault
dpkg:处理 gnome2-user-guide (--remove)时出错:
子进程·post-removal script·返回了错误号·139
正在删除 ubuntu-docs ...
Segmentation fault
dpkg:处理 ubuntu-docs (--remove)时出错:
子进程·post-removal script·返回了错误号·139
在处理时有错误发生:
gnome2-user-guide
ubuntu-docs
E: Sub-process /usr/bin/dpkg returned an error code (1)
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#7

帖子 xiehuoli » 2007-03-27 17:48

你安装了什么东西之后变这样的?
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#8

帖子 xiehuoli » 2007-03-27 17:52

提示是你GDM出了问题哦
你删除它也不可以?
或者重新安装
用dpkg -i 安装试下
dpkg -r 删除
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
头像
shaojz2005
帖子: 278
注册时间: 2006-07-13 13:01
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 shaojz2005 » 2007-03-27 18:13

好像出现依赖性问题一般换一个源就可以解决了
木才
帖子: 3
注册时间: 2007-08-11 21:59
送出感谢: 0
接收感谢: 0

#10

帖子 木才 » 2007-09-04 19:16

我的也出现这问题,79个软件包139错误,换了2次源也没改观,
回复

回到 “老旧版本支持”