[问题]如何编译last.fm?

为当前最终发行版之前的所有版本提供支持
回复
头像
qkthomas
帖子: 503
注册时间: 2006-12-16 22:05
来自: 肇庆
送出感谢: 0
接收感谢: 0
联系:

[问题]如何编译last.fm?

#1

帖子 qkthomas » 2007-03-27 23:07

我用的是AMD64的UBUNTU,屡次编译last.fm不成功,编译成功的朋友可以分享以下经验吗?比如,需要安装什么编译包,出了QT4还需要什么?
最后几段代码:
webservice.cpp:116: warning: unused parameter ‘error’
webservice.cpp:116: warning: unused parameter ‘errorString’
webservice.cpp: In member function ‘void WebService::metaDataRadioFinished(const QByteArray&)’:
webservice.cpp:350: warning: unused variable ‘errCode’
webservice.cpp:351: warning: unused variable ‘discovery’
webservice.cpp: In member function ‘void WebService::neighboursFinished(int, bool)’:
webservice.cpp:1124: warning: converting to ‘int’ from ‘float’
webservice.cpp: In member function ‘void WebService::similarArtistsFinished(int, bool)’:
webservice.cpp:1706: warning: unused variable ‘streamable’
webservice.cpp: In member function ‘void WebService::searchTagFinished(int, bool)’:
webservice.cpp:1769: warning: converting to ‘int’ from ‘float’
webservice.cpp: In member function ‘void WebService::makeXmlRpcCall(QByteArray, const char*, bool, Http*)’:
webservice.cpp:2536: warning: unused variable ‘id’
/usr/bin/moc-qt4 -DQT_NO_DEBUG_STREAM -DQT_NO_DEBUG -DQT_PLUGIN -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtXml -I/usr/include/qt4 -I.. -I../libLastFMTools -I../build -I../build webservice.h -o ../build/moc_webservice.cpp
g++ -c -pipe -O2 -Wall -W -D_REENTRANT -fPIC -DQT_NO_DEBUG_STREAM -DQT_NO_DEBUG -DQT_PLUGIN -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtXml -I/usr/include/qt4 -I.. -I../libLastFMTools -I../build -I../build -o ../build/moc_webservice.o ../build/moc_webservice.cpp
rm -f libservice_web.so
g++ -shared -o libservice_web.so ../build/webservice.o ../build/moc_webservice.o -L/usr/lib -L../../bin -lLastFMTools ../build/Loqqer.o -lQtXml -L/build/buildd/qt4-x11-4.2.0/lib -lQtGui -L/usr/X11R6/lib -laudio -lXt -lpng -lSM -lICE -lXrender -lXrandr -lXfixes -lXcursor -lXinerama -lfreetype -lXext -lX11 -lQtNetwork -lQtCore -lfontconfig -lz -lm -lglib-2.0 -ldl -lpthread
/usr/bin/ld: ../build/Loqqer.o: relocation R_X86_64_32S against `QString::shared_null' can not be used when making a shared object; recompile with -fPIC
../build/Loqqer.o: could not read symbols: 错误的值
collect2: ld returned 1 exit status
make[1]: *** [../../bin/services/libservice_web.so] 错误 1
make[1]: Leaving directory `/home/qkthomas/last.fm-1.1.3/src/webservice'
make: *** [sub-src_webservice-make_default] 错误 2
回复

回到 “老旧版本支持”