当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]安装gcc/g++时无法安装,出现如下提示怎么办?------已解决
帖子发表于 : 2007-03-28 7:55 

注册: 2007-02-11 20:42
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
我在终端中运行如下命令来安装gcc/g++时无法安装,出现如下提示:
tao@tao-desktop:~$ sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.0) 但是它将不会被安装
E: 无法安装的软件包

然后我又依据提示用apt-get install 来安装libc6-dev和g++,但是无法安装成功,请高手教我解决的方法。谢谢~~~


最后由 tao17388 编辑于 2007-04-02 17:26,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-03-28 8:04 

注册: 2007-03-22 2:04
帖子: 180
送出感谢: 0 次
接收感谢: 0 次
你的是6.06的还是6.10的,源用的是dapper还是edgy?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-03-28 13:06 

注册: 2007-02-11 20:42
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
我用的6.10的,但是不知道源用的是dapper还是edgy?我不理解dapper和edgy有什么区别。可能是dapper吧,好像在安装其他软件时在终端上看到源的网址后面都有个dappper.下面是我所用源的列表:
deb http://ubuntu.cn99.com/ubuntu/ dapper main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ dapper-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ dapper-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ dapper-backports main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu-cn/ dapper main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ dapper main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ dapper-security main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ dapper-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu-cn/ dapper main restricted universe multiverse
deb http://cn.archive.ubuntu.com/ubuntu dapper main restricted universe multiverse
deb http://cn.archive.ubuntu.com/ubuntu dapper-security main restricted universe multiverse
deb http://cn.archive.ubuntu.com/ubuntu dapper-updates main restricted universe multiverse
deb http://cn.archive.ubuntu.com/ubuntu dapper-backports main restricted universe multiverse
deb http://mirror.lupaworld.com/ubuntu/ubuntu-cn dapper main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu dapper-security main restricted universe multiverse
deb-src http://cn.archive.ubuntu.com/ubuntu dapper main restricted universe multiverse
deb-src http://cn.archive.ubuntu.com/ubuntu dapper-security main restricted universe multiverse
deb-src http://cn.archive.ubuntu.com/ubuntu dapper-updates main restricted universe multiverse
deb-src http://cn.archive.ubuntu.com/ubuntu dapper-backports main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted universe multiverse


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-03-28 13:30 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
sudo aptitude install build-essential


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-03-28 14:39 

注册: 2007-02-11 20:42
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
我用4楼提供的方法,运行了几次结果如下,没有安装上任何东西,我所在的网络速度很慢,且经常掉线,出现这样的结果是不是与网络的速度有关?请指教~~

~$ sudo aptitude install build-essential
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在初始化软件包状态... 完成
创建标签数据库... 完成
下列软件包是“破损”的:
libc6-dev
下列软件包将被自动安装:
g++ g++-4.0 libstdc++6-4.0-dev
下列“新”软件包将被安装。
build-essential g++ g++-4.0 libstdc++6-4.0-dev
0 个软件包被升级,新安装5 个, 0 个将被删除, 同时 0 个将不升级。
需要获取 6572kB 的存档。 解包后将要使用 25.5MB。
下列软件包存在未满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.3.6-0ubuntu20.4) 但是 2.4-1ubuntu12 已安装
Resolving dependencies...
open: 6229; closed: 4997; defer: 0; conflict/break: 6 .在分配的时间内未找到解决方案。加把劲再试试?[Y/n]Y
Resolving dependencies...
open: 12643; closed: 9995; defer: 0; conflict/break: 6 o在分配的时间内未找到解决方案。加把劲再试试?[Y/n]Y


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-03-28 15:35 

注册: 2006-06-29 17:30
帖子: 482
送出感谢: 0 次
接收感谢: 0 次
楼主你的源错了,应该使用edgy的源,到wiki上看看新手入门指南吧。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-03-28 17:45 

注册: 2007-02-11 20:42
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
如何知道我的系统是dapper还是edgy的?
运行cat /etc/issue结果如下:
~$ cat /etc/issue
Ubuntu 6.10 \n \l
运行 dpkg -l ubuntu-docs结果如下:
$ dpkg -l ubuntu-docs
期望状态=未知(u)/安装(i)/删除(r)/清除(p)/保持(h)
| 当前状态=未(n)/已安装(i)/仅存配置(c)/仅解压缩(U)/配置失败(F)/不完全安装(H)
|/ 错误?=(无)/保持(?)/须重装(R)/两者兼有(#) (状态,错误:大写=故障)
||/ 名称 版本 简介
+++-==============-==============-============================================
ii ubuntu-docs 6.10.4 The Ubuntu Documentation Project

我应该用dapper还是edgy的源?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译