当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装gcc时出现这样的对话该怎么办阿??
帖子发表于 : 2005-10-22 11:01 

注册: 2005-10-12 13:13
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
这是代码
ananias@ananias:~$ sudo apt-get install gcc
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
cpp-4.0: 依赖: gcc-4.0-base (= 4.0.1-4ubuntu9) 但是 4.0.2-2 正要被安装
gcc: 依赖: gcc-4.0 (>= 4.0.1-2) 但是它将不会被安装
gij-4.0: 依赖: gcc-4.0-base (= 4.0.1-4ubuntu9) 但是 4.0.2-2 正要被安装
libgcj6: 依赖: gcc-4.0-base (= 4.0.1-4ubuntu9) 但是 4.0.2-2 正要被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

root@ananias:/home/ananias# apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 完成
下列软件包将被【卸载】:
amarok amarok-gstreamer bluez-pin bug-buddy capplets-data
contact-lookup-applet cpp cpp-4.0 eclipse-base eclipse-jdt
eclipse-jdt-common eclipse-pde eclipse-pde-common eclipse-platform
eclipse-platform-common eclipse-rcp eclipse-rcp-common eclipse-sdk eog
evince evolution evolution-data-server evolution-exchange evolution-plugins
evolution-webcal file-roller firefox firefox-gnome-support gcalctool
gconf-editor gconf2 gdm gedit gij gij-4.0 gnome-about gnome-app-install
gnome-applets gnome-applets-data gnome-btdownload gnome-control-center
gnome-cups-manager gnome-games gnome-media gnome-netstatus-applet
gnome-nettool gnome-panel gnome-panel-data gnome-pilot gnome-pilot-conduits
gnome-session gnome-spell gnome-system-monitor gnome-system-tools
gnome-terminal gnome-utils gnome-volume-manager gnomemeeting
gstreamer0.8-gnomevfs gstreamer0.8-misc gstreamer0.8-plugins
gstreamer0.8-vorbis gthumb gtkhtml3.8 gucharmap hal-device-manager
hwdb-client java-gcj-compat kubuntu-desktop libbonobo2-0 libbonobo2-common
libbonoboui2-0 libcamel1.2-6 libebook1.2-5 libecal1.2-3 libedata-book1.2-2
libedata-cal1.2-1 libedataserver1.2-4 libedataserverui1.2-6 libeel2-2
libegroupwise1.2-8 libexchange-storage1.2-0 libgcj6 libgcj6-awt
libgcj6-common libgconf2-4 libgnome-desktop-2 libgnome2-0 libgnome2-common
libgnome2-perl libgnome2-vfs-perl libgnomecupsui1.0-1 libgnomeui-0
libgnomevfs2-0 libgnomevfs2-common libgsf-1 libgstreamer-gconf0.8-0
libgtkhtml3.8-15 libgucharmap4 libhsqldb-java libidl0 liblpint-bonobo0
libmetacity0 libnautilus-extension1 liborbit2 libpanel-applet2-0 librsvg2-2
librsvg2-common libservlet2.3-java libswt3.1-gtk-java libswt3.1-gtk-jni
libtotem-plparser0 metacity nautilus nautilus-cd-burner nautilus-sendto
openoffice.org2 openoffice.org2-base openoffice.org2-gnome python-gnome2
python-gnome2-extras python-pyorbit python2.4-gnome2 python2.4-gnome2-extras
python2.4-pyorbit rhythmbox serpentine sound-juicer totem totem-xine
tsclient ubuntu-desktop update-manager update-notifier vino yelp
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 136 个软件包,有 1 个软件未被升级。
需要下载 0B 的软件包。
解压缩后将会空出 439MB 的空间。
您希望继续执行吗?[Y/n]

这么多软件将被卸载,我该 怎么办阿???
在新利得里也是这样阿 ???凄凉。。。。。。。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-10-22 11:14 
头像

注册: 2005-08-29 14:49
帖子: 1119
地址: 杭州
送出感谢: 0 次
接收感谢: 3
系统没升级?


_________________
用心×恒 | 豆瓣 | 门户 | Blog


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-10-22 11:19 

注册: 2005-10-12 13:13
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
新装的5.10版!!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-10-22 11:38 
头像

注册: 2005-08-29 14:49
帖子: 1119
地址: 杭州
送出感谢: 0 次
接收感谢: 3
在新立得里选择 gcc-xxx gcc-xxx-base注意xxx要一致


_________________
用心×恒 | 豆瓣 | 门户 | Blog


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-10-22 11:44 

注册: 2005-10-12 13:13
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
我 在系统里装了两个桌面系统,一个是 默认的 ,还有个 是kde 现在在kde
里一升级,就如那张列表所言全卸光了。原来默认的 桌面系统都 没了,怎么办阿 ???

还有 gcc 3.4 安装了 是不是就 可以了阿??好象最新的 都 装不了。。。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-10-22 11:46 
头像

注册: 2005-08-29 14:49
帖子: 1119
地址: 杭州
送出感谢: 0 次
接收感谢: 3
有gcc 3.4也够了。

我用的是升级,原来的gcc 3.3保留,自动新增了gcc 4.0.1

自己指定 gcc 和gcc 对应版本的base

从提示看 你要装的gcc 版本和 gcc base 版本不一致


_________________
用心×恒 | 豆瓣 | 门户 | Blog


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-10-22 11:53 

注册: 2005-10-12 13:13
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
有一个gcc-3.4 gcc-xxx-base这个有好几个 3.3 3.4 4.0 都 有
是 不是有文题阿??
还有我 怎么把原来那个gnome 回去阿??
不太喜欢kde的显示效果!!谢谢!!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译