我装了JAVA1.5 也改了环境变量 为什么版本还是1.4的?

为当前最终发行版之前的所有版本提供支持
回复
zuii
帖子: 65
注册时间: 2007-03-17 10:11
送出感谢: 0
接收感谢: 0
联系:

我装了JAVA1.5 也改了环境变量 为什么版本还是1.4的?

#1

帖子 zuii » 2007-03-28 17:52

谢谢了。。。我的环境变量信息是
export JAVA_HOME=/zuii/Desktop/安装文件/jdk1.5.0_11/
export PATH=$JAVA_HOME/bin:$PATH:$JAVA_HOME/bin
export CLASSPATH=.:$JAVA_HOME/lib/tools.jar:$JAVA_HOME/lib/dt.jar:$CLASSPATH

我在profile bash.bashrc environment 都改了
头像
xport
帖子: 1277
注册时间: 2006-05-19 21:23
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 xport » 2007-03-28 19:17

因为:

1) 在/usr/bin里面还有一个符号链接,指向/etc/alternatives/java
2) 而/etc/alternatives/java也是一个符号链接,指向真正的java程序
3) 你自己的java配置放在了$PATH环境变量的最后面,所以系统先找到/usr/bin/java了

如果要解决这个办法,可以把你自己安装的新版本的Java加入alternatives !

具体做法,请 man update-alternatives
其实我是一个演员!-http://blog.csdn.net/xport/
回复

回到 “老旧版本支持”