当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [讨论]一个奇怪的问题:为什么新编译的内核有一定的几率进不了系统?
帖子发表于 : 2007-03-28 21:32 

注册: 2007-03-08 17:28
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
刚刚编译的2.6.20.1内核,有时启动引导到第二项:mounting root file system时,不能正常引导(没显示ok)
然后就会卡在“waiting for root file system”上
不过这只是以一定的几率出现,有时是能正常引导并进入系统的
而用官方老内核的话从来不会出这种问题

不知到底是什么原因?如何解决?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-03-28 21:59 
头像

注册: 2006-09-02 14:18
帖子: 5308
地址: 汉桑城
送出感谢: 1
接收感谢: 1
编译的问题


_________________
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-03-28 22:03 

注册: 2006-09-07 22:51
帖子: 849
送出感谢: 0 次
接收感谢: 0 次
引用:
不知到底是什么原因?如何解决?

很可能是你没有把需要的东西选上


那么就用旧内核好了


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-03-28 22:23 

注册: 2007-03-08 17:28
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
dogfox 写道:
编译的问题


能不能具体一些


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-03-29 6:51 

注册: 2006-04-29 14:54
帖子: 1187
地址: 山东
送出感谢: 0 次
接收感谢: 0 次
可能是你在编译时没有将ext2\ext3文件系统编译进去,或者你的是SATA硬盘,但你没有将SATA支持编译进去吧?


_________________
学会看置顶帖、精华帖。
学会使用搜索。
常见问题解答和发帖需知


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-03-29 9:25 
头像

注册: 2007-03-07 9:35
帖子: 198
送出感谢: 0 次
接收感谢: 0 次
lisir 写道:
可能是你在编译时没有将ext2\ext3文件系统编译进去,或者你的是SATA硬盘,但你没有将SATA支持编译进去吧?


楼上的正确,确实很多情况下是没有把要用的文件系统编译进去,估计没把SATA编译进去的居多,俺经常忘了把SATA搞进去,呵呵。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译