关于更新内核和i386的问题

为当前最终发行版之前的所有版本提供支持
回复
ouyanghere
帖子: 36
注册时间: 2007-02-11 1:46
送出感谢: 0
接收感谢: 0

关于更新内核和i386的问题

#1

帖子 ouyanghere » 2007-03-28 22:51

采用i386安装光盘安装的系统,在看wiki的时候看到说,对于更新内核的命令为

sudo apt-get install linux-686,不明白为什么是以686而不是以386结尾啊

现在的i686因该是i386构架的扩展吧 

在安装的时候,是不是内核会自行辨认cpu的架构?

现在的酷睿双核(非酷睿2双核)是怎么样的架构?

在论坛上好象看到说什么建议i386内核升级到i686的,到底是不是和这个一样了啊

我是个新手,正在努力的从wiki和别的地方学习中,等待7.04和新的ATI驱动,看到了这些就向大家请教,我的

提问里可能有很多不对的地方,请大家见谅,帮助我,谢谢了,看了许多,都又些混乱了,呵呵
头像
avauntage
帖子: 570
注册时间: 2005-09-22 10:15
来自: 北京
送出感谢: 0
接收感谢: 0

#2

帖子 avauntage » 2007-03-29 10:20

这个很久以前讨论过,你在论坛里面搜搜就有。
i386可以简单的认为是586之前的那些机器,686支持Pentium以后的机器,686-smp版支持超线程和双核。当然所有的cpu都是向前兼容的,所以即使酷睿双核的机器也可以装个i386的内核,只不过有点像让刘翔去参加骑慢车比赛,有点浪费。
7.04版把686和686-smp合并了,叫做linux-generic。去装个7.04吧,不要浪费你的机器。
空手把锄头,步行骑水牛;人在桥上过,人流水不流。
307WRC
帖子: 480
注册时间: 2006-12-13 22:50
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 307WRC » 2007-03-29 12:10

我用 AthlonXP ,在那一步我更新的是 sudo apt-get install linux-K7
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#4

帖子 dogfox » 2007-03-29 12:18

CPU不一样,内核也会不同
请认真的看wiki
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
回复

回到 “老旧版本支持”