命令行界面下的乱码问题

为当前最终发行版之前的所有版本提供支持
回复
utnubuubuntu
帖子: 11
注册时间: 2007-03-09 9:39
送出感谢: 0
接收感谢: 0

命令行界面下的乱码问题

#1

帖子 utnubuubuntu » 2007-03-30 22:52

在命令行界面下,一些内容的显示被替换成方块了。请问这个问题应该怎么解决呢?谢谢
头像
Nile
帖子: 990
注册时间: 2006-07-15 11:20
来自: 枫叶刀市
送出感谢: 2 次
接收感谢: 0

#2

帖子 Nile » 2007-03-30 23:24

以前我也有过这问题,好像是中文字符编码设置的问题
1,首先,确定你的语言支持里Chinese是勾而不是杠。
2,如果是Win分区中文显方块很可能是fstab的问题,注意字符编码选项,贴一下我的fstab,可能有所帮助。

代码: 全选

/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
#/dev/hda1
UUID=0664CD9D64CD903B       /windows/hda1  ntfs umask=0222,uid=1000,nls=utf8       0       2
#/dev/hda5
UUID=34A4BC61A4BC2770       /windows/hda5  ntfs umask=0222,uid=1000,nls=utf8      0       2
#/dev/hda6
UUID=60002888002866EE      /windows/hda6  ntfs umask=0222,uid=1000,nls=utf8       0       2
#/dev/hda7
UUID=E2E0C772E0C74B8B       /windows/hda7  ntfs umask=0222,uid=1000,nls=utf8      0       2
#/dev/hda9
UUID=AAA8CC44A8CC112D      /windows/hda10 ntfs umask=0222,uid=1000,nls=utf8      0       2




#/dev/hda11
UUID=B8F7-ED3D   /windows/hda8  vfat umask=000,uid=1000,utf8       0       2
#/dev/hda8
UUID=0073-1E3E      /windows/hda9   vfat umask=000,uid=1000,utf8       0   2
Thinkpad T400
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#3

帖子 BigSnake.NET » 2007-03-31 13:07

命令行界面?..X模拟终端的还是console
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

Re: 命令行界面下的乱码问题

#4

帖子 dbzhang800 » 2007-03-31 15:16

utnubuubuntu 写了:在命令行界面下,一些内容的显示被替换成方块了。请问这个问题应该怎么解决呢?谢谢

终端的话,选择合适的编码

控制台的话,安装 cce或 zhcon
utnubuubuntu
帖子: 11
注册时间: 2007-03-09 9:39
送出感谢: 0
接收感谢: 0

#5

帖子 utnubuubuntu » 2007-03-31 17:00

是在控制台下的。安装了zhcon以后还是那样
头像
hualang0929
帖子: 1226
注册时间: 2006-11-11 10:23
来自: Mars
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 hualang0929 » 2007-03-31 17:20

utnubuubuntu 写了:是在控制台下的。安装了zhcon以后还是那样

搜一下,很多这种贴。
zhcon --utf8
抬头望星空一片晴,我独行,夜已渐寒……
回复

回到 “老旧版本支持”