包依赖关系被broken了,用 apt-get -f install 修复失败!

为当前最终发行版之前的所有版本提供支持
耗子
帖子: 18
注册时间: 2007-03-29 10:42
送出感谢: 0
接收感谢: 0
联系:

包依赖关系被broken了,用 apt-get -f install 修复失败!

#1

帖子 耗子 » 2007-04-02 14:53

碰到这种情况了该如何修复呢? :oops:
头像
xport
帖子: 1277
注册时间: 2006-05-19 21:23
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 xport » 2007-04-02 15:04

命令行执行sudo synaptic或是运行“新立得”后,按状态分组会看到有一个“已经损毁的软件包”,把它们标记为彻底删除后,点应用进行执行!
其实我是一个演员!-http://blog.csdn.net/xport/
头像
halida
帖子: 246
注册时间: 2006-12-30 19:50
送出感谢: 0
接收感谢: 0

#3

帖子 halida » 2007-04-02 15:05

新力得选修复就好了。
讨厌free software
怀念卖软件的时代
耗子
帖子: 18
注册时间: 2007-03-29 10:42
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 耗子 » 2007-04-02 15:26

xport 写了:命令行执行sudo synaptic或是运行“新立得”后,按状态分组会看到有一个“已经损毁的软件包”,把它们标记为彻底删除后,点应用进行执行!
其中有个包是 libstdc++ 这样的吧(名字我不大记得了),强行删掉它要卸掉好多依赖它的包哦
耗子过街,人人喊打
xiechy
帖子: 1074
注册时间: 2006-01-18 15:01
送出感谢: 0
接收感谢: 1 次

#5

帖子 xiechy » 2007-04-02 16:07

手动修复依赖关系。具体情况具体分析。
多用dpkg,少用apt,要包的话apt download下来用dpkg装。
某些情况大胆的用dpkg --force。

从debian到ubuntu或者是ubuntu到debian都是可以的,何况一两个包的依赖问题?
耗子
帖子: 18
注册时间: 2007-03-29 10:42
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 耗子 » 2007-04-02 16:53

好的,晚上回去试试看 :)
耗子过街,人人喊打
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#7

帖子 BigSnake.NET » 2007-04-02 18:01

把出错信息列出来
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
耗子
帖子: 18
注册时间: 2007-03-29 10:42
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 耗子 » 2007-04-02 20:42

BigSnake.NET 写了:把出错信息列出来
错误信息:
# apt-get check
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
cpp-4.1: Depends: gcc-4.1-base (= 4.1.1-13ubuntu5) but 4.1.2-2 is installed
gcc-4.1: Depends: gcc-4.1-base (= 4.1.1-13ubuntu5) but 4.1.2-2 is installed
libgcc1: Depends: gcc-4.1-base (= 4.1.1-13ubuntu5) but 4.1.2-2 is installed
libstdc++6: Depends: gcc-4.1-base (= 4.1.1-13ubuntu5) but 4.1.2-2 is installed
E: Unmet dependencies. Try using -f.
耗子过街,人人喊打
头像
xport
帖子: 1277
注册时间: 2006-05-19 21:23
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 xport » 2007-04-02 21:04

你是要apt-get安装哪一个软件包的时候出现这样的问题的呢?
其实我是一个演员!-http://blog.csdn.net/xport/
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#10

帖子 BigSnake.NET » 2007-04-02 22:01

代码: 全选

apt-get -f install
贴输出
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
耗子
帖子: 18
注册时间: 2007-03-29 10:42
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 耗子 » 2007-04-02 23:36

BigSnake.NET 写了:

代码: 全选

apt-get -f install
贴输出
上面已经贴出了呢 :)
耗子过街,人人喊打
耗子
帖子: 18
注册时间: 2007-03-29 10:42
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 耗子 » 2007-04-02 23:37

算了,我已经重新装了一次系统。菜鸟该要付出的时间还是要付出的
耗子过街,人人喊打
耗子
帖子: 18
注册时间: 2007-03-29 10:42
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 耗子 » 2007-04-02 23:39

现在自己用 apt-get 安装包,再也不敢双击.deb文件安装了。
耗子过街,人人喊打
KR520
帖子: 65
注册时间: 2006-04-13 10:24
送出感谢: 0
接收感谢: 0

#14

帖子 KR520 » 2007-04-03 16:55

好像有一个dipandent什么的参数可以修复这种问题,我以前试过是OK的,只是具体命令太久没用忘记了~~这个问题不需要重装的
耗子
帖子: 18
注册时间: 2007-03-29 10:42
送出感谢: 0
接收感谢: 0
联系:

#15

帖子 耗子 » 2007-04-04 22:30

KR520 写了:好像有一个dipandent什么的参数可以修复这种问题,我以前试过是OK的,只是具体命令太久没用忘记了~~这个问题不需要重装的
新手没办法啦。
耗子过街,人人喊打
回复

回到 “老旧版本支持”