当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : U盘上中文文件名乱码
帖子发表于 : 2007-04-05 19:09 

注册: 2006-11-08 6:16
帖子: 417
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
我装了好几回xubuntu 7.04测试版(Herd 3, Herd 5, Beta),都发现同一个问题:

当用移动硬盘或者U盘的时候,移动硬盘或U盘上的在Windows机器上拷贝的中文文件名,在xubuntu下乱码,而xubuntu下拷贝进去的中文文件名,到windows下也是乱码。

不知道这到底是bug还是什么地方设置的问题?可是我以前用xubuntu 6.10的时候没有这个问题呀。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-04-08 17:53 

注册: 2006-11-08 6:16
帖子: 417
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
看来没有别人碰到过这个问题,呜呜。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-04-08 18:15 

注册: 2007-02-13 15:24
帖子: 1485
地址: 地球
送出感谢: 0 次
接收感谢: 0 次
编码问题,搜索论坛。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-04-08 18:43 
头像

注册: 2007-01-24 22:07
帖子: 1417
地址: http://adqin.cn
送出感谢: 0 次
接收感谢: 0 次
字体的问题。
两个系统互相没有对方的对应的或相近的字体。
我也是7.04,用u盘还没有遇见这样的问题。
问下:你的系统字体装完全没有。

方法:系统->首选项->字体

选中中文项,再点击应用。
这样还不行,就得另加微软的字体了。这个可以看看论坛里的字体美化帖子。
就是那样做的。


_________________
时光流转 淘帮帮 淘宝推荐 潼南网 你问我答


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-04-09 5:03 

注册: 2006-11-08 6:16
帖子: 417
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
应该不是字体问题,因为文件名改成英文之后,里面的中文字都能看到。

我一开始就意识到是文件系统的编码问题,但找了很多地方,都没找到。而且,之前我用6.10版本,根本就不存在这个问题,所以很疑惑。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-04-09 5:26 

注册: 2006-11-08 6:16
帖子: 417
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
刚才在这里找到有关解决办法:
http://wiki.ubuntu.org.cn/%E4%BC%98%E7% ... 4%E7%90%86

我还没有试。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-05-29 22:47 
头像

注册: 2007-05-05 23:59
帖子: 2032
地址: 嘉兴
送出感谢: 0 次
接收感谢: 1
我的光盘中文文件名也显示的乱码,一直在找解决的办法。都找了一个晚上了还没解决,累死了。 :em96


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-05-29 22:54 

注册: 2006-12-13 22:50
帖子: 480
送出感谢: 0 次
接收感谢: 0 次
ubuntu 系统用的编码是 UTF-8 ,windows用的是 GB***** 这样的


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-05-29 23:13 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
挂载选项加上 utf8


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-05-30 20:20 

注册: 2006-11-08 6:16
帖子: 417
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
我是楼主,没想到现在还有人在回我的这个帖子。我再说明一下当时的情况:

当时我用的是Beta版,4月19日之后正式版安装没有再出现中文文件名乱码的事情。我想是当时版本的问题,因为当时我卸载再手动挂载就没有问题。

7楼的问题没有描述很清楚,比如你有没有去看fstab文件中CDROM挂载的参数是否是utf8?或者测试过先umount光驱再手动挂载(写全参数)之后还有这个问题?等等,如此都测试完毕以后才能确定到底是什么问题。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-05-30 20:50 
头像

注册: 2006-09-02 21:41
帖子: 124
地址: 江苏南京
送出感谢: 0 次
接收感谢: 0 次
我觉得还应该是编码的问题,windows默认是使用本地的语言的,也就是用GBK(简体)或者BIG5(繁体)
ubuntu默认使用utf-8,但是在ubuntu下拷贝是可以的。
初步鉴定编码不一致


_________________
http://www.iviai.com.cn
C2.6/384M DDR266/Samsung80G+ST160G/MMX44064bit64M/DVD-rw


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-05-31 20:32 

注册: 2007-02-22 21:12
帖子: 92
送出感谢: 0 次
接收感谢: 0 次
我的U 盘压根就不能用在7.04上


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-07-05 8:26 

注册: 2007-01-15 9:45
帖子: 205
送出感谢: 0 次
接收感谢: 0 次
我的光盘也会出现乱码,不过还没有试过挂载时加自己的参数,都是系统自行挂载的,我去试试


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译