[问题]ubuntu源问题越来越大了....

为当前最终发行版之前的所有版本提供支持
回复
头像
Nile
帖子: 990
注册时间: 2006-07-15 11:20
来自: 枫叶刀市
送出感谢: 2 次
接收感谢: 0

[问题]ubuntu源问题越来越大了....

#1

帖子 Nile » 2007-04-08 8:29

这一段源怎么老是不太正常?或者是我机器的原因?

总是不能完全获取列表,最头痛的是

代码: 全选

 子进程 gzip 返回了一个错误号 (1)

代码: 全选

无法下载 ftp://debian.ustc.edu.cn/ubuntu/dists/edgy-backports/restricted/binary-i386/Packages.bz2  无法打开文件 /var/lib/apt/lists/partial/debian.ustc.edu.cn_ubuntu_dists_edgy-backports_restricted_binary-i386_Packages - open (2 No such file or directory)
并且个人感觉源里的软件不是很齐,我在网上找的程序要wxgtk-2.6.3-1ark.i586支持,源里怎么也找不到,关于GUI C++开发的好多包都找不到,(或者是因为我的源太旧了?)

这是我用的源
#台湾的源
deb http://opensource.nchc.org.tw/ubuntu/ edgy main multiverse restricted universe
deb http://opensource.nchc.org.tw/ubuntu/ edgy-updates main multiverse restricted universe
deb http://opensource.nchc.org.tw/ubuntu/ edgy-backports main multiverse restricted universe
deb http://opensource.nchc.org.tw/ubuntu/ edgy-security main multiverse restricted universe

#代码:
deb http://mirror.rootguide.org/ubuntu/ edgy main restricted universe multiverse
deb-src http://mirror.rootguide.org/ubuntu/ edgy main restricted universe multiverse
deb http://mirror.rootguide.org/ubuntu/ edgy-updates main restricted universe multiverse
deb-src http://mirror.rootguide.org/ubuntu/ edgy-updates main restricted universe multiverse
deb http://mirror.rootguide.org/ubuntu/ edgy-backports main restricted universe multiverse
deb-src http://mirror.rootguide.org/ubuntu/ edgy-backports main restricted universe multiverse
deb http://mirror.rootguide.org/ubuntu/ edgy-security main restricted universe multiverse
deb-src http://mirror.rootguide.org/ubuntu/ edgy-security main restricted universe multiverse
deb http://mirror.rootguide.org/ubuntu/ edgy-proposed main multiverse restricted universe
deb-src http://mirror.rootguide.org/ubuntu/ edgy-proposed main restricted universe multiverse
deb http://mirror.rootguide.org/ubuntu-cn/ edgy main multiverse restricted universe
#传说中的中国科技大学 速度: 5M/s
deb ftp://debian.ustc.edu.cn/ubuntu edgy main restricted universe multiverse
deb ftp://debian.ustc.edu.cn/ubuntu edgy-security main restricted universe multiverse
deb ftp://debian.ustc.edu.cn/ubuntu edgy-updates main restricted universe multiverse
deb ftp://debian.ustc.edu.cn/ubuntu edgy-backports main restricted universe multiverse
deb ftp://debian.ustc.edu.cn/ubuntu edgy-proposed main restricted universe multiverse


#欧洲,此为官方源,推荐使用
deb http://archive.ubuntu.com/ubuntu/ edgy main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ edgy-security main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ edgy-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ edgy-proposed main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ edgy main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ edgy-security main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ edgy-updates main restricted universe multiverse
另外中国科大和兰州大学的源好像有些问题,速度虽然一流,但不敢用。

还有一点,索引包的头文件是什么格式的?为什么会出现
gzip: stdin: not in gzip format
这样的错误?

谢谢!

代码: 全选

Thinkpad T400
头像
wyg1258
帖子: 654
注册时间: 2006-09-12 19:44
来自: whu
送出感谢: 0
接收感谢: 0

#2

帖子 wyg1258 » 2007-04-08 9:13

现在没有那个原 很好用的~~~ :?
头像
Nile
帖子: 990
注册时间: 2006-07-15 11:20
来自: 枫叶刀市
送出感谢: 2 次
接收感谢: 0

#3

帖子 Nile » 2007-04-08 9:21

Failed to fetch http://cn.archive.ubuntu.com/ubuntu/dis ... Sources.gz Sub-process gzip returned an error code (1)
Failed to fetch http://cn.archive.ubuntu.com/ubuntu/dis ... Sources.gz Sub-process gzip returned an error code (1)
Failed to fetch http://cn.archive.ubuntu.com/ubuntu/dis ... ackages.gz Sub-process gzip returned an error code (1)
晕死!我手工下载了Source.gz,用gzip解压就没任何问题,怎么让apt-get作就出错!!

看来以后要手动升级了。。。
Thinkpad T400
头像
magisu
帖子: 202
注册时间: 2005-12-31 21:23
送出感谢: 0
接收感谢: 0

#4

帖子 magisu » 2007-04-08 9:58

我用USTC的很好啊,10M/S(校内),200K/S(校外),没什么问题。
老子很生气,后果不严重。
头像
akilq
帖子: 328
注册时间: 2007-02-03 21:40
来自: 花花世界
送出感谢: 0
接收感谢: 1 次

#5

帖子 akilq » 2007-04-08 10:38

我最近用cn99也是,没有刚刚装ubuntu的时候那么完善,而且我升级到7.04已经2次出现错误而不成功了!不知道7.04什么时候出正式版~~~期待!!!
头像
Nile
帖子: 990
注册时间: 2006-07-15 11:20
来自: 枫叶刀市
送出感谢: 2 次
接收感谢: 0

#6

帖子 Nile » 2007-04-08 10:57

好像解决一部分了:
http://ubuntuforums.org/showthread.php? ... zip2+error

把有误的http换成ftp就成了,但貌似速度极慢......
Thinkpad T400
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#7

帖子 skyx » 2007-04-08 11:00

magisu 写了:我用USTC的很好啊,10M/S(校内),200K/S(校外),没什么问题。
我就在ustc千里之遥的校外,至少1M/S

ustc的7.04相当稳定
no security measure is worth anything if an attacker has physical access to the machine
回复

回到 “老旧版本支持”