[问题]怎么装不上这个软件的?

为当前最终发行版之前的所有版本提供支持
回复
头像
jessinio
帖子: 26
注册时间: 2006-10-19 16:55
送出感谢: 0
接收感谢: 0
联系:

[问题]怎么装不上这个软件的?

#1

帖子 jessinio » 2007-04-09 18:10

sudo apt-get -f install python-twisted 不行的,为什么??

jessinio@nio2host:~$ sudo apt-get -f install python-twisted
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
bittorrent: Depends: python-psyco but it is not going to be installed
python-twisted: Depends: python-twisted-mail (>= 0.3) but it is not going to be installed
Depends: python-twisted-lore (>= 0.2) but it is not going to be installed
Depends: python-twisted-names (>= 0.3) but it is not going to be installed
Depends: python-twisted-news (>= 0.2) but it is not going to be installed
Depends: python-twisted-runner (>= 0.2) but it is not going to be installed
Depends: python-twisted-web (>= 0.6) but it is not going to be installed
Depends: python-twisted-words (>= 0.4) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-04-09 18:15

依赖不能满足而已。
● 鸣学
头像
jessinio
帖子: 26
注册时间: 2006-10-19 16:55
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 jessinio » 2007-04-09 18:29

那怎么装??
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#4

帖子 BigSnake.NET » 2007-04-09 19:30

sudo aptitude install python-twisted
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
jessinio
帖子: 26
注册时间: 2006-10-19 16:55
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 jessinio » 2007-04-09 19:47

能不能说一下为什么sudo apt-get -f install python-twisted 装不了??
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#6

帖子 BigSnake.NET » 2007-04-09 19:48

代码: 全选

       -f, --fix-broken
              Fix;  attempt  to  correct  a system with broken dependencies in
              place. This option, when used with install/remove, can omit  any
              packages  to permit APT to deduce a likely solution. Any Package
              that are specified must completely correct the problem. The  op‐
              tion is sometimes necessary when running APT for the first time;
              APT itself does not allow broken package dependencies  to  exist
              on a system. It is possible that a system’s dependency structure
              can be so corrupt as to require manual intervention (which  usu‐
              ally  means  using dselect(8) or dpkg --remove to eliminate some
              of the offending packages). Use of this option together with  -m
              may  produce  an  error  in some situations. Configuration Item:
              APT::Get::Fix-Broken.

^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
回复

回到 “老旧版本支持”