当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 配置apache出现问题:You don't have permission to access
帖子发表于 : 2007-04-10 12:35 

注册: 2006-09-27 3:38
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
在配置apache完成之后,一切显示正常,在默认documentroot下面调试也完全可以,但是使用
/etc/apache2/sites-available# sudo gedit default
修改documentroot地址为:
DocumentRoot /media/sda5/work/web
<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
allow from all
Satisfy all
</Directory>
<Directory /media/sda5/work/web >
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
# This directive allows us to have apache2's default start page
# in /apache2-default/, but still have / go to the right place
#RedirectMatch ^/$ /apache2-default/
</Directory>
sda5为我挂载的原windows系统的D盘,分区格式为FAT32,名为web的文件夹权限也已经打开,但是在访问
http://127.0.0.1/
的时候出现
Forbidden
You don't have permission to access / on this server.
Apache/2.2.3 (Ubuntu) PHP/5.2.1 Server at 127.0.0.1 Port 80

documentroot指向路径,如果是/var/www/public_file/则使用正常,/media/sda5/work/web则出错。

/etc/fstab 里面的数据为:
# /dev/sda5 -- converted during upgrade to edgy
UUID=1421-3182 /media/sda5 vfat defaults,utf8,umask=007,gid=46 0 0

请高手帮忙,在线等。。。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-04-10 13:43 

注册: 2006-09-27 3:38
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
自己顶起来.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-04-10 17:50 

注册: 2006-09-27 3:38
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
再顶。。。。。。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-04-10 20:06 
头像

注册: 2006-07-08 9:21
帖子: 1917
地址: University of Science and Technology Beijing
送出感谢: 1
接收感谢: 0 次
如果你没有主文档的话,apache会要去list,你又没开。。
不如
<Directory /media/sda5/work/web >
Options Indexes FollowSymLinks MultiViews All
AllowOverride None
Order allow,deny
allow from all
# This directive allows us to have apache2's default start page
# in /apache2-default/, but still have / go to the right place
#RedirectMatch ^/$ /apache2-default/
</Directory>


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-04-10 20:11 

注册: 2006-09-27 3:38
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
恩,但是我的问题还是没有解决。。。。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-04-10 20:59 
头像

注册: 2007-01-24 22:07
帖子: 1417
地址: http://adqin.cn
送出感谢: 0 次
接收感谢: 0 次
hehe. 你的问题我以前遇到过。看了很多的帖子还是没有解决。
估计是其中什么地方出错了,我决得主要是主文件的位置的问题
而位置问题又涉及到权限,属主什么的,反正我是搞烦了的

如果楼主不是搞服务器的话,可以先试试XAMPP,论坛里搜搜就可以找到。


_________________
时光流转 淘帮帮 淘宝推荐 潼南网 你问我答


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-04-11 8:44 
头像

注册: 2006-07-08 9:21
帖子: 1917
地址: University of Science and Technology Beijing
送出感谢: 1
接收感谢: 0 次
那就是sudo chmod 777 -R /media/sda5/work/web


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-04-11 10:10 

注册: 2006-09-27 3:38
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
那就是sudo chmod 777 -R /media/sda5/work/web

=====
这个早就试过了,不成。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-04-11 10:12 

注册: 2006-09-27 3:38
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
回6楼:
如果实在解决不了,我再试一下XAMPP
现在好像确定是web文件夹的权限无法修改引起的。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译