请教7.04beta应安装什么版本的zlib1g-dev和libssl-dev

为当前最终发行版之前的所有版本提供支持
回复
TurtleRock
帖子: 63
注册时间: 2006-10-06 11:07
送出感谢: 0
接收感谢: 0

请教7.04beta应安装什么版本的zlib1g-dev和libssl-dev

#1

帖子 TurtleRock » 2007-04-10 22:47

因为必须登陆dr.com才能上网,因此无法apt-get
build-essential在安装盘里面用,已经安装。
但是编译dr.com还必须用到zlib1g-dev与libssl-dev
发现以前下载的在6.06上可以用的版本在7.04beta上无法安装,提示说依赖关系不足,需要zlib1g和libssl,但是查询这两个都已经安装,我想是不是版本不对?
在google上搜索到debain库里面的,不知道能用不,而且很多,不知道用哪个版本?
http://ftp.riken.go.jp/pub/Linux/debian ... l/?C=M;O=A
http://ftp.debian.org/debian/pool/main/o/openssl/
那么与7.04beta对应的zlib1g-dev与libssl-dev版本应该是哪个版本?
请指教,谢谢。
leopard10
帖子: 59
注册时间: 2006-05-21 14:11
送出感谢: 0
接收感谢: 0

#2

帖子 leopard10 » 2007-04-10 23:13

你应该需要
    zlib1g-dev
    libssl-dev
    zlib1g
    libssl0.9.8
TurtleRock
帖子: 63
注册时间: 2006-10-06 11:07
送出感谢: 0
接收感谢: 0

#3

帖子 TurtleRock » 2007-04-11 11:09

it's libssl-dev_0.9.8c-4build1_i386.deb & zlib1g-dev_1.2.3-13ubuntu4_i386.deb
I have found it last night by keywords "libssl-dev_0.9.8" "ubuntu"
other verision is not supported.

but I found that drcomsuite cannot be compiled on 7.04beta, does it because of the 2.6.20-12 kernel? I don't know

I try to modify the /usr/src/linux-headers-2.6.20-12/include/net/inet_common.h, and deleted the const word.
extern const struct proto_ops inet_stream_ops;
extern const struct proto_ops inet_dgram_ops;
as bellow:
extern struct proto_ops inet_stream_ops;
extern struct proto_ops inet_dgram_ops;

compiled successfully, but run it , it overflow
wzh@ubuntu-wzh:~/drcom$ sudo drcomcd
1176303281 DEBUG drcomcd: Redirecting stderr to /var/log/drcomcd...
*** stack smashing detected ***: drcomcd terminated
Aborted (core dumped)

why? How to use dr.com?
leopard10
帖子: 59
注册时间: 2006-05-21 14:11
送出感谢: 0
接收感谢: 0

#4

帖子 leopard10 » 2007-04-11 17:21

compile the kernel source yourself if you can.
that will be convenient if you want compile some software.
回复

回到 “老旧版本支持”