启动时,会跳到字符界面再进入图形界面

为当前最终发行版之前的所有版本提供支持
绿野风烟
帖子: 15
注册时间: 2005-12-10 23:21
送出感谢: 0
接收感谢: 0
联系:

启动时,会跳到字符界面再进入图形界面

#1

帖子 绿野风烟 » 2007-04-10 23:58

启动时,在fsck~~~~~~~~~~时会跳到字符界面再进入图形界面

该怎么办,哪位帮帮忙,谢谢。
leopard10
帖子: 59
注册时间: 2006-05-21 14:11
送出感谢: 0
接收感谢: 0

#2

帖子 leopard10 » 2007-04-11 0:09

fsck应该不会每次都有吧?
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

#3

帖子 Element » 2007-04-11 8:07

每开机30次一次例行的检查硬盘逻辑错误的。
没什么的。
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
头像
hualang0929
帖子: 1226
注册时间: 2006-11-11 10:23
来自: Mars
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 hualang0929 » 2007-04-11 8:14

没事硬盘干嘛检查,禁了它就行了
抬头望星空一片晴,我独行,夜已渐寒……
头像
drivel
帖子: 1917
注册时间: 2006-07-08 9:21
来自: University of Science and Technology Beijing
送出感谢: 1 次
接收感谢: 0
联系:

#5

帖子 drivel » 2007-04-11 8:35

hualang0929 写了:没事硬盘干嘛检查,禁了它就行了
以防万一的啊
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2007-04-11 12:56

多半是有什么分区错误,才会每次进去
● 鸣学
头像
yang_hui1986527
帖子: 888
注册时间: 2006-03-04 23:10
来自: 江西高安
送出感谢: 0
接收感谢: 2 次
联系:

#7

帖子 yang_hui1986527 » 2007-04-11 13:08

Element 写了:每开机30次一次例行的检查硬盘逻辑错误的。
没什么的。
这个好像一直这样的
赫赫
QQ:273247606
EMAIL:yanghui1986527@gmail.com
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#8

帖子 stlxv » 2007-04-11 13:18

yang_hui1986527 写了:
Element 写了:每开机30次一次例行的检查硬盘逻辑错误的。
没什么的。
这个好像一直这样的
赫赫
习惯了就没什么了
PHP是最好的语言!不服来战!
绿野风烟
帖子: 15
注册时间: 2005-12-10 23:21
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 绿野风烟 » 2007-04-12 0:49

是每次都这样,可也能正常进去,就是在进入图形界面之前要在跳到那停好久,有点不舒服.
头像
wangliuru
帖子: 69
注册时间: 2007-04-09 13:35
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 wangliuru » 2007-04-12 9:40

好像是改动

/etc/fstab

文件

找到最后的对应pass的那个值改成零

lz试试? 这是我的做法

先备份
绿野风烟
帖子: 15
注册时间: 2005-12-10 23:21
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 绿野风烟 » 2007-04-13 0:05

wangliuru 写了:好像是改动

/etc/fstab

文件

找到最后的对应pass的那个值改成零

lz试试? 这是我的做法

先备份


我的已经是0了,下面是我那个文件的内容:
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/hda3
UUID=92523201-dfb2-4efb-bf67-e0ffd1c10493 / ext3 defaults,errors=remount-ro 0 1
# /dev/hda1
UUID=688C5FFC8C5FC36C /media/hda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/hda5
UUID=FC83-7B2F /media/hda5 vfat defaults,utf8,umask=007,gid=46 0 1
# /dev/hda6
UUID=F8EF-FEB5 /media/hda6 vfat defaults,utf8,umask=007,gid=46 0 1
# /dev/hda7
UUID=983C-1B32 /media/hda7 vfat defaults,utf8,umask=007,gid=46 0 1
# /dev/hda4
UUID=5caa6e12-7a83-4396-b322-db0516d5ac6a none swap sw 0 0
/dev/hdd /media/cdrom0 udf,iso9660 user,noauto 0 0
~
头像
wangliuru
帖子: 69
注册时间: 2007-04-09 13:35
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 wangliuru » 2007-04-13 2:51

pass对应的是最后一个数字

你上面很清楚是1阿
applnk
帖子: 1485
注册时间: 2007-02-13 15:24
来自: 地球
送出感谢: 0
接收感谢: 0

#13

帖子 applnk » 2007-04-13 2:57

代码: 全选

sudo tune2fs -c 100000

系统每重启动30次,检测磁盘一次,改为每重启100000次,才检查磁盘。

PS:我没试过,不知道是不是真的。
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#14

帖子 zhuqin_83 » 2007-04-13 3:29

applnk你在那里的阿?难道和我一样?

reiserfs是每次启动都要检查,除非你把/etc/init.d/checkfs.sh删掉,不然一定会这样。
其实这样也有好处,你断电的时候重启就会自动修复文件系统,也花不了什么时间。

ext3是每30次检查,花相当多的时间的,很不爽。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
TurtleRock
帖子: 63
注册时间: 2006-10-06 11:07
送出感谢: 0
接收感谢: 0

#15

帖子 TurtleRock » 2007-04-13 19:55

gksudo gedit /etc/fstab最后一行全部改成0
回复

回到 “老旧版本支持”