当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]启动beryl失败
帖子发表于 : 2007-04-11 20:51 

注册: 2007-02-15 21:02
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
设置成随系统启动beryl失败。手动在终端输入beryl-manager出来:
qq@ubuntu:~$ sudo beryl-manager
Password:
qq@ubuntu:~$ Xlib: extension "XFree86-DRI" missing on display ":0.0".
XGL Absent, checking for NVIDIA
Nvidia Absent, checking for texture_from_pixmap
texture_from_pixmap Present
beryl: No composite extension


我的xorg.conf:
Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "aticonfig-Screen[0]" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"

# /dev/input/event
# for USB
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "0"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-04-11 21:15 

注册: 2007-02-17 12:24
帖子: 192
送出感谢: 0 次
接收感谢: 0 次
xgl没有启动吧?


_________________
梦.:如此短暂 http://d.ream.at


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-04-11 21:23 

注册: 2007-02-15 21:02
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
ls的能说的详细点吗?如何启动?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-04-11 21:29 

注册: 2007-02-17 12:24
帖子: 192
送出感谢: 0 次
接收感谢: 0 次
MS这篇文章非常适合你看:
http://forum.ubuntu.org.cn/viewtopic.php?t=35403


_________________
梦.:如此短暂 http://d.ream.at


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-04-11 22:55 

注册: 2007-02-15 21:02
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
还是不行。该了系统很卡,又改回来了


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-04-11 23:07 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
sudo?为什么??


_________________
● 鸣学


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-04-11 23:44 

注册: 2007-02-15 21:02
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
sudo beryl-manager?


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-04-12 15:08 

注册: 2007-02-17 12:24
帖子: 192
送出感谢: 0 次
接收感谢: 0 次
beryl-manager不需要sudo


_________________
梦.:如此短暂 http://d.ream.at


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-04-14 22:30 

注册: 2007-02-15 21:02
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
Xlib: extension "XFree86-DRI" missing on display ":0.0".
这是什么意思?

另外现在我每次启动X时开始显示器黑屏,显示:信号超出范围。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-04-14 22:33 

注册: 2007-02-15 21:02
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
sudo习惯了。不需要root权限的情况下用sudo会有哪些问题呢?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Sogou [Spider] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译