[求助]ubuntu6.10 安装 mysql-4.1.7

为当前最终发行版之前的所有版本提供支持
回复
yin0710
帖子: 2
注册时间: 2007-04-11 22:43
送出感谢: 0
接收感谢: 0

[求助]ubuntu6.10 安装 mysql-4.1.7

#1

帖子 yin0710 » 2007-04-11 22:58

用synaptic安装的都是5.x版本
但是我却想安装4.1.7 / 4.x版本
我下载了mysql-4.1.7.tar.gz
解压缩后输入了./configure这个指令
出现error...大概是说没有安装linuxthreads
我下载linuxthreads但是却不懂如何安装
我解压缩后输入make的指令...都是error
yin0710
帖子: 2
注册时间: 2007-04-11 22:43
送出感谢: 0
接收感谢: 0

#2

帖子 yin0710 » 2007-04-12 10:54

推~~请帮帮忙!!谢谢
ziyun
帖子: 262
注册时间: 2007-03-29 12:59
送出感谢: 0
接收感谢: 0

#3

帖子 ziyun » 2007-04-12 11:03

你去下二制版本的,解压后只要执行一个mysql_install_db就好了(看INSTALL文件)
我在ubuntu下尝试编译软件,没一次成功,所以放弃了
我用redhat的时候每一次都成功
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#4

帖子 stlxv » 2007-04-12 12:04

没事最好不要自己编译这种BT软件
PHP是最好的语言!不服来战!
头像
drivel
帖子: 1917
注册时间: 2006-07-08 9:21
来自: University of Science and Technology Beijing
送出感谢: 1 次
接收感谢: 0
联系:

#5

帖子 drivel » 2007-04-12 13:10

把 linuxthread解压到mysql文件夹里,看看linuxthread能否安装
假设mysql就在mysql中

创建 linuxthreads 手册,该手册是关于线程 API 的很棒的参考资料(也适用于 NPTL):

make -C ../mysql/linuxthreads/man

安装 linuxthreads 手册:

make -C ../mysql/linuxthreads/man install
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 karron » 2007-04-12 20:52

karron@karronqiu:~$ apt-cache search -n mysql-server
mysql-server - mysql database server (meta package depending on the latest version)
mysql-server-4.1 - mysql database server (transitional package)
mysql-server-5.0 - mysql database server binaries


源里面明明有mysql4.1, 都不知道自己搜索一下. 一个个怎么都这样???
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
回复

回到 “老旧版本支持”