当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]从610升级到704之后kontract起不来了
帖子发表于 : 2007-04-12 7:57 

注册: 2007-01-21 20:56
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
从610升级到704之后kontract起不来了,郁闷

kontact -v
Qt: 3.3.7
KDE: 3.5.6
Kontact: 1.2.4

ERROR: Communication problem with kontact, it probably crashed.
KCrash: Application 'kontact' crashing...

the debug info

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1242638640 (LWP 17780)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6 0xb7e3ea8c in Kontact::Plugin::part () from /usr/lib/libkpinterfaces.so.1
#7 0x0805e7e0 in ?? ()
#8 0x08256800 in ?? ()
#9 0x00000000 in ?? ()


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-04-12 13:41 

注册: 2007-01-21 20:56
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
Capability LSM initialized
------------[ cut here ]------------
kernel BUG at mm/mmap.c:2191!
invalid opcode: 0000 [#1]
Modules linked in: capability commoncap deflate zlib_deflate twofish twofish_common serpent blowfish des sha256 sha1 crypto_null fuse
CPU: 0
EIP: 0060:[<c019e60b>] Not tainted VLI
EFLAGS: 00210202 (2.6.19.2 #2)
EIP is at exit_mmap+0xcb/0xe0
eax: 00000000 ebx: 00000001 ecx: c1477d40 edx: c118f780
esi: 00000000 edi: d4282200 ebp: 0000fd00 esp: caf4bddc
ds: 0068 es: 0068 ss: 0068
Process kontact (pid: 3404, ti=caf4a000 task=cad48550 task.ti=caf4a000)
Stack: 00000000 caf4bde8 00000000 000029cd c06412ec d4282200 cad48550 00000001
c016acd2 0000fd00 c016f79e 00000007 cad48030 293c9100 c0182a12 00000000
cad48660 00000008 00000009 caf4be94 084dd3d4 00000009 00000000 0000fd00
Call Trace:
[<c016acd2>] mmput+0x22/0x70
[<c016f79e>] do_exit+0xee/0x7c0
[<c0182a12>] unqueue_me+0x42/0x90
[<c016fe96>] do_group_exit+0x26/0x60
[<c01778be>] get_signal_to_deliver+0x23e/0x380
[<c0159718>] do_notify_resume+0x98/0x7b0
[<c0169620>] default_wake_function+0x0/0x10
[<c0184502>] sys_futex+0x92/0x140
[<c01b8b8c>] vfs_ioctl+0x5c/0x270
[<c015a21e>] work_notifysig+0x13/0x25
[<c015a19f>] restore_all+0x0/0x18
[<c015007b>] alsa_timer_init+0x6b/0x1d0
=======================
Code: 75 17 0f 20 d8 0f 22 d8 eb 0f 8d b6 00 00 00 00 89 f0 e8 f9 fe ff ff 89 c6 85 f6 75 f3 8b 5f 74 85 db 75 07 83 c4 14 5b 5e 5f c3 <0f> 0b ea dc ef 4d c0 8f 08 eb ee 8d 76 00 8d bc 27 00 00 00 00
EIP: [<c019e60b>] exit_mmap+0xcb/0xe0 SS:ESP 0068:caf4bddc
<1>Fixing recursive fault but reboot is needed!

dmesg里发现这个
看来是LSM的原因,我把lsm模块去掉了,还是有问题
下午我在内核里把lsm直接禁用看看


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-04-12 23:16 

注册: 2007-01-21 20:56
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
事实证明不是LSM的问题
我把lsm支持在内核里去掉了,重新编译内核也不行


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译