奇怪,移动硬盘插上没有反应

为当前最终发行版之前的所有版本提供支持
回复
superman05
帖子: 143
注册时间: 2006-09-02 21:23
来自: Nanjing China
送出感谢: 0
接收感谢: 0

奇怪,移动硬盘插上没有反应

#1

帖子 superman05 » 2007-04-12 21:56

奇怪,移动硬盘插上没有反应
我装了ntfs-3g,对外部设备是否启用ntfs-3g挂载都无法识别移动硬盘,移动灯亮,但是没有自动打开文件夹,/media里也没有
貌似是我从6.06升级到6.10后就不行了,u盘是可以的。请问我该怎么办啊?下面是我的/etc/fstab
# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/hda9 :
UUID=c4ff7aa3-2daf-445c-b432-5d653e3c5ba7 / ext3 defaults,errors=remount-ro 0 1
# Entry for /dev/hda8 :
UUID=cb7a8163-38e5-4eed-a828-bc8529c77a35 /home ext3 defaults 0 2
# Entry for /dev/hda1 :
UUID=1ED0CF8DD0CF6A1B /media/hda1 ntfs-3g defaults,locale=LC_CTYPE=zh_CN.UTF-8;LC_NUMERIC=en_US.UTF-8;LC_TIME=en_US.UTF-8;LC_COLLATE=en_US.UTF-8;LC_MONETARY=en_US.UTF-8;LC_MESSAGES=en_US.UTF-8;LC_PAPER=en_US.UTF-8;LC_NAME=en_US.UTF-8;LC_ADDRESS=en_US.UTF-8;LC_TELEPHONE=en_US.UTF-8;LC_MEASUREMENT=en_US.UTF-8;LC_IDENTIFICATION=en_US.UTF-8 0 1
# Entry for /dev/hda5 :
UUID=e0000839-49b6-4f3b-b0a0-c8811bb3e2de /media/hda5 ext3 defaults 0 2
# Entry for /dev/hda6 :
UUID=C68827E98827D6A9 /media/hda6 ntfs-3g defaults,locale=LC_CTYPE=zh_CN.UTF-8;LC_NUMERIC=en_US.UTF-8;LC_TIME=en_US.UTF-8;LC_COLLATE=en_US.UTF-8;LC_MONETARY=en_US.UTF-8;LC_MESSAGES=en_US.UTF-8;LC_PAPER=en_US.UTF-8;LC_NAME=en_US.UTF-8;LC_ADDRESS=en_US.UTF-8;LC_TELEPHONE=en_US.UTF-8;LC_MEASUREMENT=en_US.UTF-8;LC_IDENTIFICATION=en_US.UTF-8 0 1
# Entry for /dev/hda7 :
UUID=9bccdc93-4429-4202-b356-f851a6d838d6 none swap sw 0 0
/dev/hdb /media/cdrom0 udf,iso9660 user,noauto 0 0
ASUS Z91V,1.73GHz,512M,60G,x700 64M;
Arch & windows xp
头像
xrfang
帖子: 1116
注册时间: 2006-12-08 10:21
送出感谢: 0
接收感谢: 0

#2

帖子 xrfang » 2007-04-13 8:04

很有可能是移动硬盘老化了,有可能就要报废 :) 我的就是这样。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#3

帖子 eexpress » 2007-04-13 8:42

是看dmesg|tail的信息先,然后看udev进程有没。然后看/etc/mtab。或者df -h的信息。
● 鸣学
superman05
帖子: 143
注册时间: 2006-09-02 21:23
来自: Nanjing China
送出感谢: 0
接收感谢: 0

#4

帖子 superman05 » 2007-04-13 12:43

嗯,今天我插上移动硬盘,到是识别了,可是没法挂载,说是无法挂载卷,我开启了ntfs-3g写支持
dmesg|tail

代码: 全选

[17179980.032000] sda: Write Protect is off
[17179980.032000] sda: Mode Sense: 27 00 00 00
[17179980.032000] sda: assuming drive cache: write through
[17179980.032000] SCSI device sda: 156301488 512-byte hdwr sectors (80026 MB)
[17179980.036000] sda: Write Protect is off
[17179980.036000] sda: Mode Sense: 27 00 00 00
[17179980.036000] sda: assuming drive cache: write through
[17179980.036000]  sda: sda1 sda2
[17179980.060000] sd 0:0:0:0: Attached scsi disk sda
[17179980.080000] sd 0:0:0:0: Attached scsi generic sg0 type 0
cat /etc/mtab

代码: 全选

/dev/hda9 / ext3 rw,errors=remount-ro 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
/sys /sys sysfs rw,noexec,nosuid,nodev 0 0
varrun /var/run tmpfs rw,noexec,nosuid,nodev,mode=0755 0 0
varlock /var/lock tmpfs rw,noexec,nosuid,nodev,mode=1777 0 0
procbususb /proc/bus/usb usbfs rw 0 0
udev /dev tmpfs rw,mode=0755 0 0
devshm /dev/shm tmpfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
lrm /lib/modules/2.6.17-11-generic/volatile tmpfs rw 0 0
/dev/hda8 /home ext3 rw 0 0
/dev/disk/by-uuid/1ED0CF8DD0CF6A1B /media/hda1 fuse rw,nosuid,nodev,noatime,allow_other 0 0
/dev/hda5 /media/hda5 ext3 rw 0 0
/dev/disk/by-uuid/C68827E98827D6A9 /media/hda6 fuse rw,nosuid,nodev,noatime,allow_other 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
请问该怎么办啊?
ASUS Z91V,1.73GHz,512M,60G,x700 64M;
Arch & windows xp
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#5

帖子 eexpress » 2007-04-13 12:52

ntfs-3g,是要自己写fstab的。
/dev/disk/by-uuid/C68827E98827D6A9 /media/hda6 fuse rw,nosuid,nodev,noatime,allow_other 0 0
怎么是fuse? 不是ntfs-3g吗
● 鸣学
superman05
帖子: 143
注册时间: 2006-09-02 21:23
来自: Nanjing China
送出感谢: 0
接收感谢: 0

#6

帖子 superman05 » 2007-04-13 13:19

不知道啊
/etc/fstab我没有自己改过
装ntfs写支持是按照论坛上的一个帖子,装了一个ntfs-config貌似
然后在系统工具-ntfs configure tool里打开内部和外部设备的写支持的
ASUS Z91V,1.73GHz,512M,60G,x700 64M;
Arch & windows xp
头像
kingkongmok
帖子: 338
注册时间: 2006-03-23 14:48
送出感谢: 2 次
接收感谢: 2 次

#7

帖子 kingkongmok » 2007-04-14 7:57

在windows下可否打开?
用lsusb+mount是否能打开?
回复

回到 “老旧版本支持”