当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : fcitx中的字体大小设置有时候会无效
帖子发表于 : 2007-04-14 8:31 
头像

注册: 2006-03-23 14:48
帖子: 328
送出感谢: 2
接收感谢: 2
1,使用gdm启动的gnome,我的gnome的输入法是用im-switch启动的,im-switch 是在/etc/X11/Xsession.d/中启动的。fcitx显示字体偏小,所以~/.fcitx/config中对字体设置,但无效.gnome只能用默认大小显示fcitx,很别扭。

2,如果进入gnome后退出fcitx的deamon,然后手动再启动fcitx的话,~/.fcitx/config中对字体设置就能生效。

3,如果使用~/.xinitrd来设定startx在icewm之前运行好fcitx的话,~/.fcitx/config中对字体设置就能生效。

4,/.xinitrd中启动gnome-session的话很多东西和原来不同,不习惯,没有做尝试。

请教为何在gdm启动的gnome,~/.fcitx/config中对字体设置就不能成功?

另外,请问我每次使用startx启动rox+icewm后,状态栏总是多一个空白的rox项,一点就没有,很麻烦,怎么解决?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-04-14 13:03 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
因为你的X dpi没设好

fcitx在gdm启动时启动的话,使用的是X 的默认dpi设置,
进入gnome后,setting-deamon会按照你在字体->DPI的设置来重设DPI,这时你的dpi就正常了


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-04-14 13:56 
头像

注册: 2007-02-21 17:06
帖子: 221
地址: 广州
送出感谢: 0 次
接收感谢: 0 次
在/usr/share/fcitx/data/config设置应该可以的。
~/.fcitx/config应该是用户的设置,就是不明白为什么设置不生效


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-04-16 21:09 
头像

注册: 2006-03-23 14:48
帖子: 328
送出感谢: 2
接收感谢: 2
BigSnake.NET 写道:
因为你的X dpi没设好

fcitx在gdm启动时启动的话,使用的是X 的默认dpi设置,
进入gnome后,setting-deamon会按照你在字体->DPI的设置来重设DPI,这时你的dpi就正常了

没有动过相关设置。
在gdm启动的gnome中,font的dpi设置一直是96。
只能找到设置中的font-详细-dpi这一个填写数值的地方而已,找不到其他了

怎么看在下中查看当前的dpi?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译