当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 关于Ctrl+Alt+F1,登录,停止gdm
帖子发表于 : 2007-04-14 13:37 

注册: 2007-04-13 19:11
帖子: 85
地址: Fujian,China
送出感谢: 0 次
接收感谢: 0 次
我在装NVIDIA驱动的时候
按Ctrl+Alt+F1,登录,停止gdm
sudo /etc/init.d/gdm stop
之后就是是黑屏了,只有个白色的光标一闪一闪
这正常吗?为什么我执行
udo sh nvidia-linux-x86-1.0-9631-pkg1.run
没有反应,而且也退不出来


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-04-14 13:38 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
虚拟机?


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-04-14 13:41 

注册: 2007-04-13 19:11
帖子: 85
地址: Fujian,China
送出感谢: 0 次
接收感谢: 0 次
不是啊!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-04-14 13:42 

注册: 2007-04-13 19:11
帖子: 85
地址: Fujian,China
送出感谢: 0 次
接收感谢: 0 次
一种可行的方法是手动安装驱动程序:
1. 到http://www.nvidia.com/下载驱动程序文件NVIDIA-Linux-x86-1.0-9631-pkg1.run
2. 删除原来的驱动(如果你装过驱动)
sudo apt-get --purge remove nvidia-glx
3. 备份当前的显示设置,这样可以在驱动安装失败时恢复到原来的设置
sudo cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf
4. 安装驱动程序编译环境
sudo apt-get install build-essential linux-headers-`uname -r`
5.禁止系统使用默认的驱动
sudo gedit /etc/default/linux-restricted-modules-common
在最后的双引号中添加nv,即“”改成“nv”
6.按Ctrl+Alt+F1,登录,停止gdm
sudo /etc/init.d/gdm stop
7.进入下载的驱动安装文件 nvidia-linux-x86-1.0-9631-pkg1.run所在目录
(请确定xorg-dev软件包已经安装,编译过程中可能会用到)
sudo sh nvidia-linux-x86-1.0-9631-pkg1.run
如果提示缺少某某模块(modules),询问是否上网下载,选no;
8.安装完成后,启动gdm
sudo /etc/init.d/gdm start

我照上面的方法做到第6步就出现上面的问题


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-04-14 13:52 
头像

注册: 2007-02-21 17:06
帖子: 221
地址: 广州
送出感谢: 0 次
接收感谢: 0 次
可以在开机时直接进入那个re什么的模式安装,只有黑屏和白色的光标在闪可能是某程序卡住了,无法返回虚拟终端


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-04-14 14:25 

注册: 2007-04-13 19:11
帖子: 85
地址: Fujian,China
送出感谢: 0 次
接收感谢: 0 次
dzhsurf 写道:
可以在开机时直接进入那个re什么的模式安装,只有黑屏和白色的光标在闪可能是某程序卡住了,无法返回虚拟终端

可是这个模式好像输入任何命令都没反应啊


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-04-14 14:34 
头像

注册: 2007-02-21 17:06
帖子: 221
地址: 广州
送出感谢: 0 次
接收感谢: 0 次
是输入命令没有反应,还是有什么错误?


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-04-14 14:35 

注册: 2007-04-13 19:11
帖子: 85
地址: Fujian,China
送出感谢: 0 次
接收感谢: 0 次
就是输入命令没有反应,回车还是空的


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-04-14 14:41 
头像

注册: 2007-02-21 17:06
帖子: 221
地址: 广州
送出感谢: 0 次
接收感谢: 0 次
没遇到过这种情况。
貌似在前台终端直接 sudo /etc/init.d/gdm stop 也可以的,不一定要按Ctrl+Alt+F1


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-04-14 14:55 

注册: 2007-04-13 19:11
帖子: 85
地址: Fujian,China
送出感谢: 0 次
接收感谢: 0 次
dzhsurf 写道:
没遇到过这种情况。
貌似在前台终端直接 sudo /etc/init.d/gdm stop 也可以的,不一定要按Ctrl+Alt+F1

就是键入这个命令后我就傻了
用sudo /etc/init.d/gdm start也退不出来


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
cron
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译