当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [问题]usb鼠标与usb读卡器冲突导致鼠标不能使用的问题
帖子发表于 : 2007-04-14 17:58 

注册: 2007-03-25 19:33
帖子: 74
送出感谢: 0 次
接收感谢: 0 次
usb鼠标与usb读卡器冲突导致鼠标不能使用的问题
我的电脑是hp品牌机,自带读卡器。
我的鼠标是usb口的,9合一读卡器是也是用的usb控制器。
安装完ubuntu后,出现鼠标不能识别的问题,很是郁闷,但是偶尔它又能被识别出来,我怀疑是ubuntu对读卡器驱动识别不正确,导致usb控制器出问题,鼠标不能使用。
现在我解决的办法就是开机的时候把鼠标拔出来,进入系统了再插入鼠标,这样就没有什么问题,其实我是不用读卡器的,很想把这个硬件禁用了,或者不要加载这个驱动,不知道如何进行,请高手赐教!!!
每次开机都要记得拔鼠标很难受啊.
插着鼠标10次有9次认不出来,郁闷.


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-04-14 21:10 

注册: 2007-03-25 19:33
帖子: 74
送出感谢: 0 次
接收感谢: 0 次
只要告诉我禁用掉读卡器,让他不要开机时影响鼠标就行了。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-04-14 21:18 
头像

注册: 2006-05-19 21:23
帖子: 1277
送出感谢: 0 次
接收感谢: 0 次
你在/etc/X11/xorg.conf中关于鼠标的配置是什么样的? 把关于鼠标的那个InputDevice Section放上来看看!


_________________
其实我是一个演员!-http://blog.csdn.net/xport/


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-04-14 22:52 

注册: 2007-03-25 19:33
帖子: 74
送出感谢: 0 次
接收感谢: 0 次
谢谢,谢谢,又是你来帮忙。
/etc/X11/xorg.conf的内容如下:
代码:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/X11/fonts/misc"
   FontPath   "/usr/share/X11/fonts/cyrillic"
   FontPath   "/usr/share/X11/fonts/100dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/75dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/Type1"
   FontPath   "/usr/share/X11/fonts/100dpi"
   FontPath   "/usr/share/X11/fonts/75dpi"
   FontPath   "/usr/share/fonts/X11/misc"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "i2c"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "type1"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us"
   Option      "XkbOptions"   "lv3:ralt_switch"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ExplorerPS/2"
   Option      "ZAxisMapping"      "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "NVIDIA Corporation NV43 [GeForce 6600]"
   Driver      "nv"
   BusID      "PCI:1:0:0"
EndSection

Section "Monitor"
   Identifier   "HP mx705"
   Option      "DPMS"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "NVIDIA Corporation NV43 [GeForce 6600]"
   Monitor      "HP mx705"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1152x864" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1152x864" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1152x864" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1152x864" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1152x864" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1152x864" "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice     "stylus" "SendCoreEvents"
   InputDevice     "cursor" "SendCoreEvents"
   InputDevice     "eraser" "SendCoreEvents"
EndSection

Section "DRI"
   Mode   0666
EndSection


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-04-15 10:08 
头像

注册: 2006-05-19 21:23
帖子: 1277
送出感谢: 0 次
接收感谢: 0 次
鼠标配置的地方不正确,你写的是使用PS/2接口的鼠标!

如果是USB接口的鼠标,请使用Option "Protocol" "IMPS/2"来设定!


_________________
其实我是一个演员!-http://blog.csdn.net/xport/


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-04-16 0:06 

注册: 2007-03-25 19:33
帖子: 74
送出感谢: 0 次
接收感谢: 0 次
谢谢谢谢!我明天试试,今天忙这实验mldonkey呢,呵呵。对了,请问,你知道mplayer的缓存怎么设置吗?我设置开启cache后每次重启都又默认没有开启了。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-04-16 12:55 

注册: 2007-03-25 19:33
帖子: 74
送出感谢: 0 次
接收感谢: 0 次
我刚试过了,还是不行。我把下面这段mouse的代码"ExplorerPS/2"改成"IMPS/2",结果还是不行。可能问题还不是出在这个配置文件上。鼠标会在开机横条走到大概第1格的时候灭掉,之后再也不亮了。无论是怎么换接口。我仍然感觉这个与读卡器有关系,麻烦再帮我看看把。
Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"


Option "Protocol" "IMPS/2"


最后由 huangfr 编辑于 2007-04-16 13:23,总共编辑了 1 次

页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-04-16 13:22 

注册: 2007-03-25 19:33
帖子: 74
送出感谢: 0 次
接收感谢: 0 次
又试了一下,鼠标应该是在启动条没走完第一格时,也就是开始走启动条后3秒就灭掉了。我还实验了一下,插入移动硬盘,硬盘灯是亮了,但我没有鼠标不知道认出磁盘没有。至少说明usb接口是通电的,那么应该就是驱动的问题了。呵呵,然后就没有头绪了。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-04-17 22:13 

注册: 2007-03-25 19:33
帖子: 74
送出感谢: 0 次
接收感谢: 0 次
没有人能给点解决的意见了吗?


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-04-18 22:00 

注册: 2007-03-25 19:33
帖子: 74
送出感谢: 0 次
接收感谢: 0 次
哦no,崩溃,难道无解吗?


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-04-18 22:09 
头像

注册: 2006-05-19 21:23
帖子: 1277
送出感谢: 0 次
接收感谢: 0 次
糟糕,好像我搞错大小写了!

确认了一下资料,如下看看:
代码:
    Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
    EndSection


_________________
其实我是一个演员!-http://blog.csdn.net/xport/


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-04-20 13:36 

注册: 2007-03-25 19:33
帖子: 74
送出感谢: 0 次
接收感谢: 0 次
艾,看来问题比较麻烦阿,我把相关配置改成
代码:
Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
    EndSection


代码:
Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"


结果都不行,麻烦xport大哥帮我看看以下两段代码是什么东西的配置文件,第二个感觉就是读写器的文件,第一和三个是什么就搞不太懂了,请问是否可以在xorg.conf文件中将读写器,或者usb控制器其他无关的东西禁止加载呢?比如删除掉。
代码:
Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection


代码:
Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection


代码:
Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-04-20 13:40 

注册: 2007-03-25 19:33
帖子: 74
送出感谢: 0 次
接收感谢: 0 次
还有一个情况就是我的鼠标是微软的IE3.0鼠标,有两个功能键,不知道这个对配置有没有影响,反正在ubuntu下这俩个功能键是不被识别的,点了没有反应。谢谢,指教。


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-04-21 16:38 

注册: 2007-03-25 19:33
帖子: 74
送出感谢: 0 次
接收感谢: 0 次
继续申请援助!!!!


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-04-22 8:40 

注册: 2007-03-25 19:33
帖子: 74
送出感谢: 0 次
接收感谢: 0 次
移动版块了,感觉还是新手区看的人多。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译