[问题]ubuntu 6.10下export LD_ASSUME_KERNEL=2.4.1的问题!

为当前最终发行版之前的所有版本提供支持
回复
kupen
帖子: 6
注册时间: 2007-04-13 17:34
送出感谢: 0
接收感谢: 0

[问题]ubuntu 6.10下export LD_ASSUME_KERNEL=2.4.1的问题!

#1

帖子 kupen » 2007-04-14 20:26

在ubuntu 6.10下使用export LD_ASSUME_KERNEL=2.4.1之后,运行任何需要使用库文件的命令都不成功,譬如键入“ls”命令后显示:

代码: 全选

kupen@kupen-desktop:~$ export LD_ASSUME_KERNEL=2.4.1
kupen@kupen-desktop:~$ ls
ls: error while loading shared libraries: librt.so.1: cannot open shared object file: No such file or directory
请问这个问题该如何解决,我需要指定内核到2.4.1来运行cadence ic设计程序。谢谢!
kupen
帖子: 6
注册时间: 2007-04-13 17:34
送出感谢: 0
接收感谢: 0

#2

帖子 kupen » 2007-04-15 21:28

没有人回答吗?是不是要换个版提问这个问题呢?
kupen
帖子: 6
注册时间: 2007-04-13 17:34
送出感谢: 0
接收感谢: 0

#3

帖子 kupen » 2007-04-17 15:43

不知道再次顶自己的帖子是否违规,但是很希望有人能够帮忙解决这个问题。
头像
xport
帖子: 1277
注册时间: 2006-05-19 21:23
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 xport » 2007-06-04 22:14

6.10 的 ls 命令依赖下面的 lib :

代码: 全选

libc.so.6 (libc6, OS ABI: Linux 2.6.0) => /lib/libc.so.6
这个是 2.6.x 内核的 ABI 标准,与 2.4.x是不兼容的!

你为什么要去修改这个参数呢?要看你具体的应用才好帮你!
其实我是一个演员!-http://blog.csdn.net/xport/
回复

回到 “老旧版本支持”