[问题]软件更新时,软件的依赖关系遇到问题

为当前最终发行版之前的所有版本提供支持
回复
一木
帖子: 75
注册时间: 2007-03-24 18:41
来自: 中国民航大学
送出感谢: 0
接收感谢: 0

[问题]软件更新时,软件的依赖关系遇到问题

#1

帖子 一木 » 2007-04-15 10:33

看在终端中的提示:
wbs@wbs-desktop:~$ sudo apt-get upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
下列的软件包的版本将保持不变:
libwnck18 nvidia-glx nvidia-glx-dev xserver-xgl
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 4 个软件未被升级。
wbs@wbs-desktop:~$ sudo apt-get install libwnck18
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libwnck18: 依赖: libatk1.0-0 (>= 1.12.1) 但是 1.11.4-0ubuntu1 正要被安装
依赖: libc6 (>= 2.4-1) 但是 2.3.6-0ubuntu20.5 正要被安装
依赖: libcairo2 (>= 1.2.4) 但是 1.2.2-0ubuntu1 正要被安装
依赖: libglib2.0-0 (>= 2.12.0) 但是 2.10.3-0ubuntu1 正要被安装
依赖: libgtk2.0-0 (>= 2.10.3) 但是 2.8.20-0ubuntu1.1 正要被安装
依赖: libpango1.0-0 (>= 1.14.5) 但是 1.12.3-0ubuntu3 正要被安装
E: 无法安装的软件包
wbs@wbs-desktop:~$ sudo apt-get install libatk1.0-0
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
libatk1.0-0 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 4 个软件未被升级。

其实依赖的那些包都已经装过提示说是最新的了
那个。。。。正要被安装是什么意思?
头像
yang_hui1986527
帖子: 888
注册时间: 2006-03-04 23:10
来自: 江西高安
送出感谢: 0
接收感谢: 2 次
联系:

#2

帖子 yang_hui1986527 » 2007-04-15 10:43

sudo apt-get install -f
看下这个可以修复依赖关系吗
QQ:273247606
EMAIL:yanghui1986527@gmail.com
头像
hualang0929
帖子: 1226
注册时间: 2006-11-11 10:23
来自: Mars
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 hualang0929 » 2007-04-15 10:44

试试在新立德 hold
抬头望星空一片晴,我独行,夜已渐寒……
ziyun
帖子: 262
注册时间: 2007-03-29 12:59
送出感谢: 0
接收感谢: 0

#4

帖子 ziyun » 2007-04-15 13:25

换下你的源,我估计你是把那些源混在一起了
我曾经这样把系统给升挂了
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#5

帖子 skyx » 2007-04-15 13:34

基本上是源混用造成的,dist-upgrade 或安装驱动时,没把握最好用官源
no security measure is worth anything if an attacker has physical access to the machine
一木
帖子: 75
注册时间: 2007-03-24 18:41
来自: 中国民航大学
送出感谢: 0
接收感谢: 0

#6

帖子 一木 » 2007-04-15 18:04

hualang0929 写了:试试在新立德 hold
怎么试?
可以具体点吗?谢谢 了


好像就是源 混了

我原来的时候添加了很多源
可是我刚刚改了那个测试的源(把原来的换掉了)还是那样

怎么办?
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#7

帖子 BigSnake.NET » 2007-04-15 18:07

aptitude
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
youngcmu
帖子: 92
注册时间: 2006-12-30 16:29
送出感谢: 0
接收感谢: 0

#8

帖子 youngcmu » 2007-04-15 18:34

BigSnake.NET 写了:aptitude
什么东西??
怎么和新立得一样,不会用,太抽象了………………………………………………
回复

回到 “老旧版本支持”