安装软件时的错误!

为当前最终发行版之前的所有版本提供支持
回复
youngcmu
帖子: 92
注册时间: 2006-12-30 16:29
送出感谢: 0
接收感谢: 0

安装软件时的错误!

#1

帖子 youngcmu » 2007-04-15 15:45

~$ sudo apt-get install gcursor
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
gcursor 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 4 个软件包没有被完全安装或卸载。
需要下载 0B 的软件包。
解压缩后会消耗掉 0B 的额外空间。
正在设置 libbcprov-java-gcj (1.33-2ubuntu3) ...
gcj-dbtool-4.1: symbol lookup error: /usr/lib/libgcj.so.70: undefined symbol:
dpkg:处理 libbcprov-java-gcj (--configure)时出错:
子进程·post-installation script·返回了错误号·2
正在设置 libglib-java-gcj (0.3.2-0ubuntu2) ...
gcj-dbtool-4.1: symbol lookup error: /usr/lib/libgcj.so.70: undefined symbol:
dpkg:处理 libglib-java-gcj (--configure)时出错:
子进程·post-installation script·返回了错误号·2
dpkg:依赖关系问题使得 libcairo-java-gcj 的配置工作不能继续:
libcairo-java-gcj 依赖于 libglib-java-gcj;然而:
软件包 libglib-java-gcj 还没有被配置。
dpkg:处理 libcairo-java-gcj (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libgtk-java-gcj 的配置工作不能继续:
libgtk-java-gcj 依赖于 libglib-java-gcj;然而:
软件包 libglib-java-gcj 还没有被配置。
libgtk-java-gcj 依赖于 libcairo-java-gcj;然而:
软件包 libcairo-java-gcj 还没有被配置。
dpkg:处理 libgtk-java-gcj (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
libbcprov-java-gcj
libglib-java-gcj
libcairo-java-gcj
libgtk-java-gcj
E: Sub-process /usr/bin/dpkg returned an error code (1)
安装任何软件都有这个提示出现,不知道什么原因???
还有就是scim的输入法配置没有办法启动。
上次由 youngcmu 在 2007-04-15 16:22,总共编辑 1 次。
头像
yhlfh
帖子: 579
注册时间: 2006-09-02 20:42
来自: 东海明珠
送出感谢: 1 次
接收感谢: 2 次

#2

帖子 yhlfh » 2007-04-15 15:49

先把这四个包全卸了,再一个一个装
Life is like a box of chocolates, you never know what you're going to get.
youngcmu
帖子: 92
注册时间: 2006-12-30 16:29
送出感谢: 0
接收感谢: 0

#3

帖子 youngcmu » 2007-04-15 16:13

sudo apt-get remove libbcprov-java-gcj libglib-java-gcj libcairo-java-gcj libgtk-java-gcj
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
软件包 libgtk-java-gcj 还未安装,因而不会被卸载
下列软件包将被【卸载】:
libbcprov-java-gcj libcairo-java-gcj libglib-java-gcj
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 3 个软件包,有 0 个软件未被升级。
有 3 个软件包没有被完全安装或卸载。
需要下载 0B 的软件包。
解压缩后将会空出 5018kB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 94035 个文件和目录。)
正在删除 libbcprov-java-gcj ...
gcj-dbtool-4.1: symbol lookup error: /usr/lib/libgcj.so.70: undefined symbol:
dpkg:处理 libbcprov-java-gcj (--remove)时出错:
子进程·post-removal script·返回了错误号·2
正在删除 libcairo-java-gcj ...
gcj-dbtool-4.1: symbol lookup error: /usr/lib/libgcj.so.70: undefined symbol:
dpkg:处理 libcairo-java-gcj (--remove)时出错:
子进程·post-removal script·返回了错误号·2
正在删除 libglib-java-gcj ...
gcj-dbtool-4.1: symbol lookup error: /usr/lib/libgcj.so.70: undefined symbol:
dpkg:处理 libglib-java-gcj (--remove)时出错:
子进程·post-removal script·返回了错误号·2
在处理时有错误发生:
libbcprov-java-gcj
libcairo-java-gcj
libglib-java-gcj
E: Sub-process /usr/bin/dpkg returned an error code (1)
这是什么原因呢???????
头像
yhlfh
帖子: 579
注册时间: 2006-09-02 20:42
来自: 东海明珠
送出感谢: 1 次
接收感谢: 2 次

#4

帖子 yhlfh » 2007-04-15 16:15

原因是: /usr/lib/libgcj.so.70: undefined symbol
Life is like a box of chocolates, you never know what you're going to get.
youngcmu
帖子: 92
注册时间: 2006-12-30 16:29
送出感谢: 0
接收感谢: 0

#5

帖子 youngcmu » 2007-04-15 16:28

sudo apt-get remove /usr/lib/libgcj.so.70
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
E: 无法找到软件包
simon@simon-desktop:~$ sudo apt-get install libgcj.so.70
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
E: 无法找到软件包 libgcj.so.70
我又搜索libgcj.so.70,发现了deb文件,下载安装但是提示说已经有了更新的版本。可是从上面来看,应该没有没有安装吧??
回复

回到 “老旧版本支持”