为什么很多包都无法安装?

为当前最终发行版之前的所有版本提供支持
回复
Quotation
帖子: 2
注册时间: 2005-10-26 13:37
送出感谢: 0
接收感谢: 0

为什么很多包都无法安装?

#1

帖子 Quotation » 2005-10-26 15:03

昨天刚装的ubuntu5.1
libc6-dev等很多东西都无法安装,象这样:
wangxl@box:~$ sudo apt-get install libc6-dev
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libc6-dev: Depends: libc6 (= 2.3.2.ds1-20ubuntu14) but 2.3.5-1ubuntu12 is to be installed
E: Broken packages

再例如:
wangxl@box:~$ sudo apt-get install drscheme
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
drscheme: PreDepends: mzscheme (>= 207) but it is not going to be installed
E: Broken packages


用的sourcelist如下:
deb http://archive.ubuntu.org.cn/ubuntu hoary main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu hoary-security main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu hoary-updates main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu-cn hoary main universe multiverse restricted
deb http://archive.ubuntu.org.cn/ubuntu hoary-backports main universe multiverse restricted
deb http://archive.ubuntu.org.cn/backports hoary-extras main universe multiverse restricted

deb http://security.ubuntu.com/ubuntu breezy-security main restricted
deb-src http://security.ubuntu.com/ubuntu breezy-security main restricted
[/quote]
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2005-10-26 15:07

改源。
● 鸣学
头像
leal
帖子: 1119
注册时间: 2005-08-29 14:49
来自: 杭州
送出感谢: 0
接收感谢: 3 次
联系:

#3

帖子 leal » 2005-10-26 15:09

libc6-dev: Depends: libc6 (= 2.3.2.ds1-20ubuntu14) but 2.3.5-1ubuntu12 is to be installed

drscheme: PreDepends: mzscheme (>= 207) but it is not going to be installed

怎么尽是hoary的源 :cry:
用心×恒 | 豆瓣 | 门户 | Blog
Quotation
帖子: 2
注册时间: 2005-10-26 13:37
送出感谢: 0
接收感谢: 0

#4

帖子 Quotation » 2005-10-26 16:51

汗…………多谢,原来hoary是老版本的…

我是照着“快速设置指南”写的sources.list,那个也该更新了
回复

回到 “老旧版本支持”