[分享]我解决x server启动失败的办法!

为当前最终发行版之前的所有版本提供支持
回复
youngcmu
帖子: 92
注册时间: 2006-12-30 16:29
送出感谢: 0
接收感谢: 0

[分享]我解决x server启动失败的办法!

#1

帖子 youngcmu » 2007-04-17 17:10

事件回放:
本人安装了ubuntu7.04的beta版本,并且花了很长的时间升级到了最新。安装了很多的软件,主题等。后来屏幕有偏移,向左。查阅了网上内容。照猫画虎,重启了N此之后,依然是不解决问题。随后进行最后一个办法,那就是安装显卡的驱动程序。要知道我的显卡可是nvidia geforce2 mx400的,虽然有人说其可以跑beryl,但是我是没有信心的。所以之前的系统都是没有安装显卡驱动。……安装驱动之后(新立得方式),重启,进入登录界面后是网格白屏,从键盘输入用户名称和密码,也是可以到桌面,但是这样实在是不爽。于是乎,卸载驱动(nvidia-glx &nvidia-glx-legacy 这两个都装了,失败)。重启之后,x server启动失败。
解决问题:
搜索一下,没有什么办法适合。难道说真的要重装系统??进入xp下,发现x11文件夹下,有4个xorg.conf的配置文件。因为不知道哪一个是正确的。所以也没有办法删除。突然想到,安装系统的时候有个系统文件的盘符,莫非……
进入安装盘的安装界面,进入x11文件夹,发现只有一个xorg.conf,复制此文件到xp的分区,退出光盘,进入xp,将刚才复制的文件复制到ubuntu系统的x11下,其他的错误的全部删除。重启进入ubuntu,成功。没有提示错误。发现桌面的偏移问题也是解决了。登录界面的分辨率也解决了。为验证,再次重启进入ubuntu,OK,没有问题。

总结:
把自己的经历和大家分享一下,我是新手,希望能给有类似情况的新手一些启示。有不对的地方大家海涵吧!
lifequan
帖子: 6
注册时间: 2007-03-18 18:34
送出感谢: 0
接收感谢: 0

#2

帖子 lifequan » 2007-04-18 6:32

我是6。10的,在实验N种调整分辨率为宽屏1280×800的方法之后,x server终于垮了……晕啊。尝试一下楼主的方法,希望也适用。
lifequan
帖子: 6
注册时间: 2007-03-18 18:34
送出感谢: 0
接收感谢: 0

#3

帖子 lifequan » 2007-04-18 6:56

成功!多谢楼主,现在就在ubuntu下面回帖了。不同之处在于我在修改xorg.conf之前就在目录之下备份了一份原始的,现在只需要进入目录,将其他几个删除,再把备份的拷回来就行了,呵呵。
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

#4

帖子 Element » 2007-04-18 8:18

多个xorg.conf,让系统怎么认啊,肯定导致错误。
不管什么时候,只能有一个。
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
头像
xport
帖子: 1277
注册时间: 2006-05-19 21:23
送出感谢: 0
接收感谢: 0
联系:

Re: [分享]我解决x server启动失败的办法!

#5

帖子 xport » 2007-04-18 8:25

youngcmu 写了:进入xp下,发现x11文件夹下,有4个xorg.conf的配置文件。
请教一下楼主用的是在Windows XP中读取Linux分区的内容的吗?如果是这个,你用的是什么软件啊?

还是说你是从Linux中丢文件到Windows分区的?
其实我是一个演员!-http://blog.csdn.net/xport/
头像
hongmy525
帖子: 236
注册时间: 2007-01-26 22:06
来自: 南宁 杭州
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 hongmy525 » 2007-04-18 18:24

我的X-window是在调整屏幕偏移以后常常出问题,就是安装了nidia的驱动以后~!!
youngcmu
帖子: 92
注册时间: 2006-12-30 16:29
送出感谢: 0
接收感谢: 0

Re: [分享]我解决x server启动失败的办法!

#7

帖子 youngcmu » 2007-04-19 12:03

xport 写了:
youngcmu 写了:进入xp下,发现x11文件夹下,有4个xorg.conf的配置文件。
请教一下楼主用的是在Windows XP中读取Linux分区的内容的吗?如果是这个,你用的是什么软件啊?

还是说你是从Linux中丢文件到Windows分区的?
在xp下可以用软件查看linux的分区啊。软件好像叫Paragon EXT2FS Anywhere,搜索一下。
youngcmu
帖子: 92
注册时间: 2006-12-30 16:29
送出感谢: 0
接收感谢: 0

#8

帖子 youngcmu » 2007-04-24 12:54

本人已经成功安装了nvidia geforce2 mx400显卡的驱动,有兴趣的查看我的帖子。
回复

回到 “老旧版本支持”