[问题] configure的时候的报错~~请高手指点~

为当前最终发行版之前的所有版本提供支持
回复
moonknight
帖子: 5
注册时间: 2007-04-17 20:55
送出感谢: 0
接收感谢: 0

[问题] configure的时候的报错~~请高手指点~

#1

帖子 moonknight » 2007-04-17 21:06

我想自己通过源代码的方式安装Gcc-4.1.1,可是configure的时候出现了以下报错,请大家帮帮忙,指导下~

代码: 全选

root@www:/home/moon/gcc-build# ../gcc-4.1.1/configure --prefix=/usr/gcc
creating cache ./config.cache
checking host system type... i686-pc-linux-gnulibc1
checking target system type... i686-pc-linux-gnulibc1
checking build system type... i686-pc-linux-gnulibc1
checking for a BSD compatible install... /usr/bin/install -c
checking whether ln works... yes
checking whether ln -s works... yes
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... no
configure: error: installation or configuration problem: C compiler cannot create executables. 

下面是config.log的内容

代码: 全选

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:600: checking host system type
configure:621: checking target system type
configure:639: checking build system type
configure:694: checking for a BSD compatible install
configure:747: checking whether ln works
configure:771: checking whether ln -s works
configure:1825: checking for gcc
configure:1938: checking whether the C compiler (gcc  ) works
configure:1954: gcc -o conftest    conftest.c  1>&5
/usr/bin/ld: crt1.o: No such file: No such file or directory
collect2: ld returned 1 exit status
configure: failed program was:

#line 1949 "configure"
#include "confdefs.h"

main(){return(0);}
头像
xport
帖子: 1277
注册时间: 2006-05-19 21:23
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 xport » 2007-04-17 21:11

不是有错误提示么?

/usr/bin/ld: crt1.o: No such file: No such file or directory

你用locate翻翻看呢?

代码: 全选

[xport@ubuntu ~] $ locate "crt1.o"
/usr/lib/crt1.o
其实我是一个演员!-http://blog.csdn.net/xport/
moonknight
帖子: 5
注册时间: 2007-04-17 20:55
送出感谢: 0
接收感谢: 0

#3

帖子 moonknight » 2007-04-17 21:41

恩~~确实没有,可是怎么解决这个问题呢?
头像
xport
帖子: 1277
注册时间: 2006-05-19 21:23
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 xport » 2007-04-17 22:08

sudo apt-get install "libc6-dev"
其实我是一个演员!-http://blog.csdn.net/xport/
moonknight
帖子: 5
注册时间: 2007-04-17 20:55
送出感谢: 0
接收感谢: 0

#5

帖子 moonknight » 2007-04-18 6:05

sudo apt-get install "libc6-dev"

好兄弟~~我过我想弄清楚点,libc6-dev,能不能不通过这种方式安装吗?比如说,机器里面有安装文件,但是机器是脱网的~有下载这东西的地方吗?也就说我想自己下载了包,然后自己搞`~~
moonknight
帖子: 5
注册时间: 2007-04-17 20:55
送出感谢: 0
接收感谢: 0

#6

帖子 moonknight » 2007-04-18 6:09

呵呵,我看你的blog了~~~好阿~~~~收藏了先~
头像
xport
帖子: 1277
注册时间: 2006-05-19 21:23
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 xport » 2007-04-18 8:11

moonknight 写了:sudo apt-get install "libc6-dev"

好兄弟~~我过我想弄清楚点,libc6-dev,能不能不通过这种方式安装吗?比如说,机器里面有安装文件,但是机器是脱网的~有下载这东西的地方吗?也就说我想自己下载了包,然后自己搞`~~
可以的,你可以通过下载相应的*.deb软件包,用dpkg -i进行安装!
用apt-get实际上就是去网上捉你需要的软件包(也就是*.deb文件,不过含依赖的部分)到你本机后,再进行安装的!
其实我是一个演员!-http://blog.csdn.net/xport/
moonknight
帖子: 5
注册时间: 2007-04-17 20:55
送出感谢: 0
接收感谢: 0

#8

帖子 moonknight » 2007-04-18 14:09

哎~~太感谢了~什么什么涕零阿来着?哦,深表涕零~~
回复

回到 “老旧版本支持”